CVE-2000-0840
CVSS10.0
发布时间 :2000-11-14 00:00:00
修订时间 :2008-09-05 16:21:59
NMCOS    

[原文]Buffer overflow in XMail POP3 server before version 0.59 allows remote attackers to execute arbitrary commands via a long USER command.


[CNNVD]Xmail缓冲区溢出漏洞(CNNVD-200011-056)

        XMail POP3 server 0.59之前的版本存在缓冲区溢出漏洞。远程攻击者可以借助超长USER命令执行任意命令。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0840
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0840
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200011-056
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/bugtraq/2000-09/0001.html
(VENDOR_ADVISORY)  BUGTRAQ  20000906 [NEWS] XMail vulnerable to a remotely exploitable buffer overflow (APOP, USER)
http://xforce.iss.net/static/5192.php
(UNKNOWN)  XF  xmail-long-user-bo
http://www.securityfocus.com/bid/1652
(VENDOR_ADVISORY)  BID  1652

- 漏洞信息

Xmail缓冲区溢出漏洞
危急 缓冲区溢出
2000-11-14 00:00:00 2005-10-20 00:00:00
远程  
        XMail POP3 server 0.59之前的版本存在缓冲区溢出漏洞。远程攻击者可以借助超长USER命令执行任意命令。

- 公告与补丁

        This vulnerability has been fixed in the latest version of XMail.

- 漏洞信息

13179
XMail POP3 Server USER Command Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2000-09-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.59 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

XMail Buffer Overflow Vulnerability
Boundary Condition Error 1652
Yes No
2000-09-07 12:00:00 2009-07-11 02:56:00
This vulnerability was first reported in a SecuriTeam advisory posted to Bugtraq on September 6, 2000.

- 受影响的程序版本

Davide Libenzi XMail 0.58
Davide Libenzi XMail 0.59

- 不受影响的程序版本

Davide Libenzi XMail 0.59

- 漏洞讨论

Versions of XMail prior to 0.59 contained multiple exploitable buffer overflows. By issuing either a USER or APOP command with arguments longer than 256 characters remote users can either crash the server or execute arbitrary code.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

This vulnerability has been fixed in the latest version of XMail.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站