CVE-2000-0752
CVSS7.2
发布时间 :2000-10-20 00:00:00
修订时间 :2008-09-05 16:21:48
NMCOS    

[原文]Buffer overflows in brouted in FreeBSD and possibly other OSes allows local users to gain root privileges via long command line arguments.


[CNNVD]FreeBSD端口brouted安装许可漏洞(CNNVD-200010-065)

        FreeBSD和可能其他OSes的brouted存在缓冲区溢出漏洞。本地用户可以借助超长命令行参数提升根目录特权。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:freebsd:freebsd:5.0FreeBSD 5.0
cpe:/o:freebsd:freebsd:3.5FreeBSD 3.5
cpe:/o:freebsd:freebsd:4.0:alpha
cpe:/o:freebsd:freebsd:5.0:alpha
cpe:/o:freebsd:freebsd:4.0FreeBSD 4.0
cpe:/o:freebsd:freebsd:4.1FreeBSD 4.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0752
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0752
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200010-065
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1629
(VENDOR_ADVISORY)  BID  1629
http://archives.neohapsis.com/archives/freebsd/2000-08/0339.html
(VENDOR_ADVISORY)  FREEBSD  FreeBSD-SA-00:43

- 漏洞信息

FreeBSD端口brouted安装许可漏洞
高危 缓冲区溢出
2000-10-20 00:00:00 2005-10-20 00:00:00
本地  
        FreeBSD和可能其他OSes的brouted存在缓冲区溢出漏洞。本地用户可以借助超长命令行参数提升根目录特权。

- 公告与补丁

        Versions of the port obtained after August 22, 2000 are not vulnerable. Newer versions of the packages are available for users who have older versions of the ports heirarchy.
        FreeBSD FreeBSD 3.5
        
        FreeBSD FreeBSD 4.0 alpha
        
        FreeBSD FreeBSD 4.0
        
        FreeBSD FreeBSD 4.1
        
        FreeBSD FreeBSD 5.0
        
        FreeBSD FreeBSD 5.0 alpha
        

- 漏洞信息

6040
FreeBSD brouted Multiple Local Overflow
Local Access Required Input Manipulation
Loss of Integrity

- 漏洞描述

Local overflows exists in brouted, a FreeBSD port. This dynamic routing daemon fails to validate input resulting in buffer overflows. With a specially crafted request, an attacker can obtain the privileges of kmem because brouted is incorrectly installed setgid kmem. A malicious user can then upgrade from the kmem privileges to root access by manipulating kernel memory resulting in a loss of integrity.

- 时间线

2000-08-28 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workarounds: (1) remove the setgid bit on the /usr/local/sbin/brouted file, (2) upgrade your entire ports collection and rebuild the brouted port, (3) deinstall the old package and install a new package dated after the correction date, (4) download a new port skeleton for the brouted port, and (5) use the portcheckout utility to automate aforementioned option (4).

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

FreeBSD Ports brouted Installation Permission Vulnerability
Configuration Error 1629
No Yes
2000-08-28 12:00:00 2009-07-11 02:56:00
This vulnerability was made public in a FreeBSD security advisory on August 28, 2000.

- 受影响的程序版本

FreeBSD FreeBSD 5.0 alpha
FreeBSD FreeBSD 5.0
FreeBSD FreeBSD 4.1
FreeBSD FreeBSD 4.0 alpha
FreeBSD FreeBSD 4.0
FreeBSD FreeBSD 3.5

- 漏洞讨论

A vulnerability exists in the FreeBSD ports package for the brouted program. Vulnerable versions of brouted were available in the ports packages for 3.5-RELEASE and 4.1-RELEASE until August 22, 2000. Subsequent installations of the ports package are not vulnerable.

brouted is incorrectly installed with setgid kmem permissions. Versions of the port released prior to August 22, 2000 had buffer overflows in the command line argument handling. This could lead to local users being able to execute arbitrary code with GID kmem permissions. This could be used to elevate privilege to that of root by manipulating kernel memory.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Versions of the port obtained after August 22, 2000 are not vulnerable. Newer versions of the packages are available for users who have older versions of the ports heirarchy.


FreeBSD FreeBSD 3.5

FreeBSD FreeBSD 4.0 alpha

FreeBSD FreeBSD 4.0

FreeBSD FreeBSD 4.1

FreeBSD FreeBSD 5.0

FreeBSD FreeBSD 5.0 alpha

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站