CVE-2000-0748
CVSS4.6
发布时间 :2000-10-20 00:00:00
修订时间 :2008-09-05 16:21:47
NMCOS    

[原文]OpenLDAP 1.2.11 and earlier improperly installs the ud binary with group write permissions, which could allow any user in that group to replace the binary with a Trojan horse.


[CNNVD]OpenLDAP 'ud'群组可写漏洞(CNNVD-200010-053)

        OpenLDAP 1.2.11及其之前的版本不正确安装权限为群组可写的ud二进制代码,该群组的任意用户可以利用该漏洞借助特洛伊木马移动二进制代码。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:openldap:openldap:1.2.9
cpe:/a:openldap:openldap:1.2.10
cpe:/a:openldap:openldap:1.2.8
cpe:/a:openldap:openldap:1.2.7
cpe:/a:openldap:openldap:1.2.11

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0748
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0748
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200010-053
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1511
(VENDOR_ADVISORY)  BID  1511
http://archives.neohapsis.com/archives/bugtraq/2000-07/0375.html
(VENDOR_ADVISORY)  BUGTRAQ  20000726 Group-writable executable in OpenLDAP

- 漏洞信息

OpenLDAP 'ud'群组可写漏洞
中危 未知
2000-10-20 00:00:00 2005-10-20 00:00:00
本地  
        OpenLDAP 1.2.11及其之前的版本不正确安装权限为群组可写的ud二进制代码,该群组的任意用户可以利用该漏洞借助特洛伊木马移动二进制代码。

- 公告与补丁

        Change the permissions for 'ud' to 755.
        In the Makefile, replace the line:
         $(LTINSTALL) $(INSTALLFLAGS) -m 775 ud $(bindir)
        with
         $(LTINSTALL) $(INSTALLFLAGS) -m 755 ud $(bindir)

- 漏洞信息

8030
OpenLDAP ud Group Write Permissions

- 漏洞描述

Unknown or Incomplete

- 时间线

2000-07-26 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

OpenLDAP 'ud' Group Writable Vulnerability
Unknown 1511
No Yes
2000-07-27 12:00:00 2009-07-11 02:56:00
Posted to BugTraq on July 26, 2000 by Christian Kleinewaechter <kleinew@Mathematik.Uni-Bielefeld.DE>.

- 受影响的程序版本

OpenLDAP OpenLDAP 1.2.11
- Debian Linux 2.2 sparc
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 arm
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Debian Linux 2.2
- Debian Linux 2.2
+ RedHat Linux 7.0 i386
+ RedHat Linux 7.0 i386
+ RedHat Linux 7.0
+ RedHat Linux 7.0
OpenLDAP OpenLDAP 1.2.10
OpenLDAP OpenLDAP 1.2.9
+ Red Hat Linux 6.2
+ RedHat Linux 6.2 i386
+ RedHat Linux 6.2 i386
OpenLDAP OpenLDAP 1.2.8
OpenLDAP OpenLDAP 1.2.7
S.u.S.E. Linux 7.0
RedHat Linux 6.2 sparc
RedHat Linux 6.2 i386
RedHat Linux 6.2 alpha

- 不受影响的程序版本

S.u.S.E. Linux 7.0
RedHat Linux 6.2 sparc
RedHat Linux 6.2 i386
RedHat Linux 6.2 alpha

- 漏洞讨论

The "Interactive LDAP Directory Server query program", ud, which ships with OpenLDAP, is installed by default mode 775. Depending on the group it is installed as this could present a security issue and possibly be used to elevate privileges.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Change the permissions for 'ud' to 755.

In the Makefile, replace the line:
$(LTINSTALL) $(INSTALLFLAGS) -m 775 ud $(bindir)
with
$(LTINSTALL) $(INSTALLFLAGS) -m 755 ud $(bindir)

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站