CVE-2000-0713
CVSS7.6
发布时间 :2000-10-20 00:00:00
修订时间 :2008-09-05 16:21:42
NMCOS    

[原文]Buffer overflow in Adobe Acrobat 4.05, Reader, Business Tools, and Fill In products that handle PDF files allows attackers to execute arbitrary commands via a long /Registry or /Ordering specifier.


[CNNVD]Adobe Acrobat / Reader / Business Tools缓冲区溢出漏洞(CNNVD-200010-036)

        运行PDF文件的Adobe Acrobat 4.05,Reader,Business Tools,和Fill In产品存在缓冲区溢出漏洞。攻击者可以通过超长/Registry或/Ordering说明符执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.6 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:adobe:acrobat_business_tools:4.0Adobe Acrobat Business Tools 4.0
cpe:/a:adobe:acrobat:4.0Adobe Acrobat 4.0
cpe:/a:adobe:acrobat_business_tools:4.05Adobe Acrobat Business Tools 4.05
cpe:/a:adobe:acrobat_reader:4.0Adobe Acrobat Reader 4.0
cpe:/a:adobe:acrobat:4.0.5Adobe Acrobat 4.0.5
cpe:/a:adobe:acrobat:3.0Adobe Acrobat 3.0
cpe:/a:adobe:acrobat_reader:4.0.5Adobe Acrobat Reader 4.0.5
cpe:/a:adobe:acrobat_reader:3.0Adobe Acrobat Reader 3.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0713
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0713
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200010-036
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1509
(VENDOR_ADVISORY)  BID  1509
http://archives.neohapsis.com/archives/bugtraq/2000-07/0382.html
(VENDOR_ADVISORY)  BUGTRAQ  20000726 [SPSadvisory#39]Adobe Acrobat Series PDF File Buffer Overflow
http://www.adobe.com/misc/pdfsecurity.html
(UNKNOWN)  CONFIRM  http://www.adobe.com/misc/pdfsecurity.html

- 漏洞信息

Adobe Acrobat / Reader / Business Tools缓冲区溢出漏洞
高危 缓冲区溢出
2000-10-20 00:00:00 2005-10-20 00:00:00
远程※本地  
        运行PDF文件的Adobe Acrobat 4.05,Reader,Business Tools,和Fill In产品存在缓冲区溢出漏洞。攻击者可以通过超长/Registry或/Ordering说明符执行任意命令。

- 公告与补丁

        Adobe has released a patch which eliminates this vulnerability:
        Adobe Acrobat Reader 4.0 5
        
        Adobe Acrobat 4.0 5
        
        Adobe Acrobat Business Tools 4.0 5
        

- 漏洞信息

9291
Adobe Acrobat Series Multiple Specifier Overflow
Local Access Required Input Manipulation
Loss of Integrity

- 漏洞描述

A local overflow exists in Acrobat products. The program fails to validate the /Registry and /Ordering strings resulting in a buffer overflow. With a specially crafted PDF file containing a very long string in /Registry or /Ordering, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2000-07-26 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Adobe has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Adobe Acrobat / Reader / Business Tools Buffer Overflow Vulnerability
Boundary Condition Error 1509
Yes Yes
2000-07-26 12:00:00 2009-07-11 02:56:00
Posted to Bugtraq on July 26, 2000 by UNYUN <shadowpenguin@backsection.net>.

- 受影响的程序版本

Adobe Reader 4.0 5
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows NT 4.0
Adobe Reader 4.0
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
Adobe Reader 3.0
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
Adobe Acrobat Business Tools 4.0 5
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
Adobe Acrobat Business Tools 4.0
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
Adobe Acrobat 4.0 5
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
Adobe Acrobat 4.0
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
Adobe Acrobat 3.0
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
Adobe Reader 4.0 5c
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
Adobe Acrobat Business Tools 4.0 5c
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
Adobe Acrobat 4.0 5c
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0

- 不受影响的程序版本

Adobe Reader 4.0 5c
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
Adobe Acrobat Business Tools 4.0 5c
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
Adobe Acrobat 4.0 5c
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0

- 漏洞讨论

Adobe Acrobat/Reader/Business Tools for Windows (Macintosh and Unix versions are not affected) does not properly handle PDF files with excessively long /Registry and /Ordering string arguments, which are located in the font CDI system information. Depending on the data entered into the strings, the application will crash or execution of arbitrary code would be made possible when opening a malicious PDF file.

- 漏洞利用

See Discussion.

- 解决方案

Adobe has released a patch which eliminates this vulnerability:


Adobe Reader 4.0 5

Adobe Acrobat 4.0 5

Adobe Acrobat Business Tools 4.0 5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站