CVE-2000-0593
CVSS5.0
发布时间 :2000-06-27 00:00:00
修订时间 :2008-09-10 15:05:10
NMCOS    

[原文]WinProxy 2.0 and 2.0.1 allows remote attackers to cause a denial of service by sending an HTTP GET request without listing an HTTP version number.


[CNNVD]SapporoWorks WinProxy缓冲区溢出漏洞(CNNVD-200006-108)

        WinProxy 2.0和2.0.1版本存在漏洞。远程攻击者通过发送不含HTTP版本号列表的HTTP GET请求导致拒绝服务。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:sapporoworks:sapporoworks_winproxy:2.0.1
cpe:/a:sapporoworks:sapporoworks_winproxy:2.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0593
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0593
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200006-108
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/4831.php
(VENDOR_ADVISORY)  XF  winproxy-get-dos(4831)
http://www.securityfocus.com/templates/archive.pike?list=1&msg=200006271417.GFE84146.-BJXON@lac.co.jp
(UNKNOWN)  BUGTRAQ  20000627 [SPSadvisory #37]WinProxy 2.0.0/2.0.1 DoS and Exploitable Buffer Overflow
http://www.securityfocus.com/bid/1400
(UNKNOWN)  BID  1400

- 漏洞信息

SapporoWorks WinProxy缓冲区溢出漏洞
中危 边界条件错误
2000-06-27 00:00:00 2006-09-22 00:00:00
远程※本地  
        WinProxy 2.0和2.0.1版本存在漏洞。远程攻击者通过发送不含HTTP版本号列表的HTTP GET请求导致拒绝服务。

- 公告与补丁

        SapporoWorks has released version 2.0.2 which eliminates the vulnerability and is available for download at the following location:
        http://homepage2.nifty.com/spw/winproxy/download.html

- 漏洞信息

1429
SapporoWorks WinProxy Malformed HTTP GET Request DoS
Denial of Service
Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2000-06-27 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SapporoWorks WinProxy Buffer Overflow Vulnerability
Boundary Condition Error 1400
Yes Yes
2000-06-27 12:00:00 2009-07-11 02:56:00
Discovered by UNYUN <shadowpenguin@backsection.net> and posted to Bugtraq on June 27, 2000 by Nobuo Miwa <n-miwa@lac.co.jp>.

- 受影响的程序版本

SapporoWorks WinProxy 2.0.1
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
SapporoWorks WinProxy 2.0
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
SapporoWorks WinProxy 2.0.2
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0

- 不受影响的程序版本

SapporoWorks WinProxy 2.0.2
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0

- 漏洞讨论

Multiple unchecked buffers exist in the POP3 and HTTP Proxy components of SapporoWorks WinProxy which could open up the possibilities of denial of service attacks or remote execution of arbitrary code.

Performing a "GET /" on port 8080 will cause WinProxy to stop responding.

The USER, PASS, LIST, RETR, and DELE commands allow for arbitrary code to be executed when strings over 312 bytes are entered. The USER and PASS command are vulnerable to buffer overflow even without authentication procedures.

- 漏洞利用

UNYUN &lt;shadowpenguin@backsection.net&gt; has released the following exploit:

- 解决方案

SapporoWorks has released version 2.0.2 which eliminates the vulnerability and is available for download at the following location:

http://homepage2.nifty.com/spw/winproxy/download.html

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站