CVE-2000-0526
CVSS5.0
发布时间 :2000-06-09 00:00:00
修订时间 :2008-09-10 15:04:55
NMCOES    

[原文]mailview.cgi CGI program in MailStudio 2000 2.0 and earlier allows remote attackers to read arbitrary files via a .. (dot dot) attack.


[CNNVD]3R Soft MailStudio 2000多重漏洞(CNNVD-200006-044)

        MailStudio 2000 2.0和更早的版本的mailview.cgi CGI程序存在漏洞。远程攻击者借助..(点 点)攻击可以读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0526
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0526
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200006-044
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1335
(VENDOR_ADVISORY)  BID  1335
http://archives.neohapsis.com/archives/bugtraq/2000-06/0081.html
(VENDOR_ADVISORY)  BUGTRAQ  20000609 Mailstudio2000 CGI Vulnerabilities [S0ftPj.4]

- 漏洞信息

3R Soft MailStudio 2000多重漏洞
中危 设计错误
2000-06-09 00:00:00 2005-10-20 00:00:00
远程※本地  
        MailStudio 2000 2.0和更早的版本的mailview.cgi CGI程序存在漏洞。远程攻击者借助..(点 点)攻击可以读取任意文件。

- 公告与补丁

        Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 漏洞信息 (20008)

3R Soft MailStudio 2000 2.0 Arbitrary File Access (EDBID:20008)
cgi remote
2000-06-09 Verified
0 s0ftpr0ject
N/A [点击下载]
source: http://www.securityfocus.com/bid/1335/info
 
MailStudio 2000 is vulnerable to multiple attacks.
 
It is possible for a remote user to gain read access to all files located on the server via the usage of the "/.." string passed to a CGI, thereby compromising the confidentiality of other users email and password, as well as other configuration and password files on the system.
 
It is also possible to set a password for those system user accounts which don't have one in place (ex: operator, gopher etc).
 
There is also a input validation vulnerability in the userreg.cgi. This CGI uses a shell to execute certain commands. Passing any command directly after %0a in the arguments of the CGI will allow a remote user to execute the commands as root.
 
userreg.cgi also has an unchecked which could allow remote attackers to execute arbitrary code as root.

Mail view vulnerability:
mailview.cgi?cmd=view&fldrname=inbox&select=1&html=../../../../../../etc/passwd

userreg.cgi vulnerability:
userreg.cgi?cmd=insert&lang=eng&tnum=3&fld1=test999%0acat</var/spool/mail/login>>/etc/passwd		

- 漏洞信息

13687
MailStudio 2000 mailview.cgi Traversal Arbitrary File Access
Remote / Network Access Information Disclosure
Loss of Confidentiality Solution Unknown
Exploit Public Third-party Verified, Uncoordinated Disclosure

- 漏洞描述

- 时间线

2000-06-09 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

3R Soft MailStudio 2000 Multiple Vulnerabilities
Design Error 1335
Yes Yes
2000-06-09 12:00:00 2009-07-11 02:56:00
File Viewing vulnerability discovered by Naif <naif@itapac.net>, buffer overflow discovered by FuSyS <fusys@s0ftpj.org>. Posted in a s0ftpj <http://www.s0ftpj.org > advisory on June 9, 2000.

- 受影响的程序版本

3R Soft MailStudio 2000 2.0
- Digital OSF/1 3.2
- HP HP-UX 9.9
- Linux kernel 2.2 .x
- Sun Solaris 8_sparc

- 漏洞讨论

MailStudio 2000 is vulnerable to multiple attacks.

It is possible for a remote user to gain read access to all files located on the server via the usage of the "/.." string passed to a CGI, thereby compromising the confidentiality of other users email and password, as well as other configuration and password files on the system.

It is also possible to set a password for those system user accounts which don't have one in place (ex: operator, gopher etc).

There is also a input validation vulnerability in the userreg.cgi. This CGI uses a shell to execute certain commands. Passing any command directly after %0a in the arguments of the CGI will allow a remote user to execute the commands as root.

userreg.cgi also has an unchecked which could allow remote attackers to execute arbitrary code as root.

- 漏洞利用

s0ftpr0ject &lt;http://www.s0ftpj.org&gt; has provided the following exploits:

Mail view vulnerability:
mailview.cgi?cmd=view&amp;fldrname=inbox&amp;select=1&amp;html=../../../../../../etc/passwd

userreg.cgi vulnerability:
userreg.cgi?cmd=insert&amp;lang=eng&amp;tnum=3&amp;fld1=test999%0acat&lt;/var/spool/mail/login&gt;&gt;/etc/passwd


Fyodor &lt;fygrave@tigerteam.net&gt; has provided the following exploit for the buffer overflow:

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站