CVE-2000-0423
CVSS5.0
发布时间 :2000-05-05 00:00:00
修订时间 :2016-10-17 22:07:00
NMCOES    

[原文]Buffer overflow in Netwin DNEWSWEB CGI program allows remote attackers to execute arbitrary commands via long parameters such as group, cmd, and utag.


[CNNVD]Netwin DNews News Server的缓冲区溢出漏洞(CNNVD-200005-029)

        Netwin DNEWSWEB公共网关程序存在缓冲区溢出漏洞,远程攻击者可以通过例如group, cmd, and utag的超长参数执行任意命令。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0423
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0423
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200005-029
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=95764950403250&w=2
(UNKNOWN)  BUGTRAQ  20000505 Alert: DNewsWeb buffer overflow
http://www.securityfocus.com/bid/1172
(UNKNOWN)  BID  1172

- 漏洞信息

Netwin DNews News Server的缓冲区溢出漏洞
中危 缓冲区溢出
2000-05-05 00:00:00 2005-10-20 00:00:00
远程※本地  
        Netwin DNEWSWEB公共网关程序存在缓冲区溢出漏洞,远程攻击者可以通过例如group, cmd, and utag的超长参数执行任意命令。

- 公告与补丁

        Netwin has released patches which rectify this issue. Download the appropriate 5.4 patch for your platform:
        ftp://ftp.netwinsite.com/pub/dnews/beta/

- 漏洞信息 (19895)

NetWin DNews 5.3 Server Buffer Overflow Vulnerability (EDBID:19895)
windows remote
2000-03-01 Verified
0 Joey__
N/A [点击下载]
source: http://www.securityfocus.com/bid/1172/info

DNews News Server is a CGI application that gives access to auser's NNTP server over the web. There are many unchecked buffers in the program, some of which can be exploited directly from any browser. Supplying an overlylong value for the "group", "cmd" and "utag" variables, and possibly others, will overwrite their respective buffers. In this manner, arbitrary code can be executed on the remote target.

http://www.exploit-db.com/sploits/19895.zip		

- 漏洞信息

13683
Netwin DNews News Server DNEWSWEB QUERY_STRING Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Third-party Verified

- 漏洞描述

- 时间线

2000-05-05 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 5.4c3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Netwin DNews News Server Buffer Overflow Vulnerability
Boundary Condition Error 1172
Yes Yes
2000-05-05 12:00:00 2009-07-11 01:56:00
Publicized in a Cerberus Information Security Advisory on May 5, 2000 by the Cerberus Security Team <CST@CERBERUS-INFOSEC.CO.UK>.

- 受影响的程序版本

NetWin DNews 5.3
- Apple Mac OS 9 9.0
- BSDI BSD/OS 4.0.1
- Digital OSF/1 3.2
- FreeBSD FreeBSD 5.0
- HP HP-UX 11.0 4
- IBM AIX 4.3.2
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 3.5.1
- Microsoft Windows NT 4.0
- SCO UNIX System V/386 Release 3.2 4.2
- Sun Solaris 8_sparc
- Sun SunOS 4.1.4

- 漏洞讨论

DNews News Server is a CGI application that gives access to auser's NNTP server over the web. There are many unchecked buffers in the program, some of which can be exploited directly from any browser. Supplying an overlylong value for the "group", "cmd" and "utag" variables, and possibly others, will overwrite their respective buffers. In this manner, arbitrary code can be executed on the remote target.

- 漏洞利用

This exploit, developed by ADM, will launch a command shell bound to a specified port.

- 解决方案

Netwin has released patches which rectify this issue. Download the appropriate 5.4 patch for your platform:

ftp://ftp.netwinsite.com/pub/dnews/beta/

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站