CVE-2000-0421
CVSS7.5
发布时间 :2000-05-11 00:00:00
修订时间 :2008-09-10 15:04:37
NMCOS    

[原文]The process_bug.cgi script in Bugzilla allows remote attackers to execute arbitrary commands via shell metacharacters.


[CNNVD]Bugzilla远程任意命令这些漏洞(CNNVD-200005-041)

        Bugzilla 中的process_bug.cgi脚本存在漏洞,远程攻击者可以通过shell元字符执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0421
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0421
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200005-041
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1199
(UNKNOWN)  BID  1199
http://archives.neohapsis.com/archives/bugtraq/2000-05/0128.html
(UNKNOWN)  BUGTRAQ  20000510 Advisory: Unchecked system(blaat $var blaat) call in Bugzilla 2.8

- 漏洞信息

Bugzilla远程任意命令这些漏洞
高危 输入验证
2000-05-11 00:00:00 2005-05-02 00:00:00
远程  
        Bugzilla 中的process_bug.cgi脚本存在漏洞,远程攻击者可以通过shell元字符执行任意命令。

- 公告与补丁

        The vendor has addressed this issue in Bugzilla versions 2.12 and later.
        Mozilla Bugzilla 2.10
        
        Mozilla Bugzilla 2.4
        
        Mozilla Bugzilla 2.6
        
        Mozilla Bugzilla 2.8
        

- 漏洞信息

58527
Bugzilla process_bug.cgi Shell Metacharacter Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Uncoordinated Disclosure

- 漏洞描述

Bugzilla contains a flaw that may allow a malicious user to execute arbitrary commands. The issue is triggered when a malicious user submits shell meta characters to the process_bug.cgi. It is possible that the flaw may allow arbitrary code execution resulting in a loss of integrity.

- 时间线

2000-05-10 Unknow
Unknow 2001-04-27

- 解决方案

Upgrade to version 2.12 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Bugzilla Remote Arbitrary Command Execution Vulnerability
Input Validation Error 1199
Yes No
2000-05-11 12:00:00 2009-07-11 01:56:00
Reported to Bugtraq on May 11, 2000 by Frank van Vliet karin@root66.nl.eu.org

- 受影响的程序版本

Mozilla Bugzilla 2.10
Mozilla Bugzilla 2.8
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows 98
- Microsoft Windows NT 3.5.1
- Microsoft Windows NT 3.5.1
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
Mozilla Bugzilla 2.6
Mozilla Bugzilla 2.4
Mozilla Bugzilla 2.14
- RedHat Linux 7.1
- RedHat Linux 7.1
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
Mozilla Bugzilla 2.12

- 不受影响的程序版本

Mozilla Bugzilla 2.14
- RedHat Linux 7.1
- RedHat Linux 7.1
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
Mozilla Bugzilla 2.12

- 漏洞讨论

Bugzilla is a web-based bug-tracking system based on Perl and MySQL. It allows people to submit bugs and catalogs them.

Bugzilla is prone to a vulnerability which may allow remote users to execute arbitrary commands on the target webserver.

When accepting a bug report, the script "process_bug.cgi" calls "./processmail" via a perl system() call argumented by a number of paramaters with values originating from user input via a web-form. There are no checks against these values for shell metacharacters by the script before insertion into the system() call.

As a result, it possible for an attacker to supply maliciously crafted input to form fields, which when submitted will cause arbitrary commands to be executed on the shell of the host running vulnerable versions of Bugzilla. Commands will be executed with the privileges of the webserver process.

- 漏洞利用

Frank van Vliet <karin@root66.nl.eu.org> has released the following exploit:

- 解决方案

The vendor has addressed this issue in Bugzilla versions 2.12 and later.


Mozilla Bugzilla 2.10

Mozilla Bugzilla 2.4

Mozilla Bugzilla 2.6

Mozilla Bugzilla 2.8

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站