CVE-2000-0391
CVSS10.0
发布时间 :2000-05-16 00:00:00
修订时间 :2008-09-10 15:04:34
NMCO    

[原文]Buffer overflow in krshd in Kerberos 5 allows remote attackers to gain root privileges.


[CNNVD]多个厂商Kerberos 5/Kerberos 4 兼容问题的krb_rd_req()函数的缓冲区溢出漏洞(CNNVD-200005-064)

        Kerberos 5中的ksu存在缓冲区溢出漏洞,远程攻击者可以利用这个漏洞获取根权限。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:cygnus:cygnus_network_security:4.0
cpe:/o:redhat:linux:6.2::alpha
cpe:/a:mit:kerberos:5_1.1.1MIT Kerberos 5 1.1.1
cpe:/a:mit:kerberos:4.0MIT Kerberos 4 4.0
cpe:/o:redhat:linux:6.2::sparc
cpe:/o:redhat:linux:6.2::i386
cpe:/a:cygnus:kerbnet:5.0
cpe:/a:mit:kerberos:5_1.0MIT Kerberos 5 krb5_1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0391
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0391
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200005-064
(官方数据源) CNNVD

- 其它链接及资源

http://www.cert.org/advisories/CA-2000-06.html
(VENDOR_ADVISORY)  CERT  CA-2000-06
http://www.securityfocus.com/bid/1220
(UNKNOWN)  BID  1220
http://www.redhat.com/support/errata/RHSA-2000-025.html
(UNKNOWN)  REDHAT  RHSA-2000:025
http://www.osvdb.org/4876
(UNKNOWN)  OSVDB  4876
http://archives.neohapsis.com/archives/freebsd/2000-05/0295.html
(UNKNOWN)  FREEBSD  FreeBSD-SA-00:20
http://archives.neohapsis.com/archives/bugtraq/2000-05/0184.html
(UNKNOWN)  BUGTRAQ  20000516 BUFFER OVERRUN VULNERABILITIES IN KERBEROS

- 漏洞信息

多个厂商Kerberos 5/Kerberos 4 兼容问题的krb_rd_req()函数的缓冲区溢出漏洞
危急 缓冲区溢出
2000-05-16 00:00:00 2005-07-27 00:00:00
远程※本地  
        Kerberos 5中的ksu存在缓冲区溢出漏洞,远程攻击者可以利用这个漏洞获取根权限。

- 公告与补丁

        MIT will release krb5-1.2 shortly, which will remedy these problems in the MIT codebase. Patches are available against krb5-1.0.x., and krb5-1.1.1
        Users upgrading to krb5-1.1.1 and compiling with the --without-krb4 option also need to apply patches against the login program to prevent a dangling else clause.
        Removing the setuid bit on the v4rcp binary will eliminate that specific vulnerability under RedHat Linux 6.2. It will not remove additional problems present if Kerberos is installed.
        Any users still using FreeBSD 2.2.5 and who have installed the optional Kerberos distribution are urged to upgrade to 2.2.8-STABLE or later. Note however that FreeBSD 2.x is no longer an officially supported version, nor are security fixes always provided.
        RedHat has released patches. See the RedHat advisory
        http://www.redhat.com/support/errata/RHSA-2000-025.html
        MIT Kerberos 5 5.0 -1.0.x
        
        MIT Kerberos 5 5.0 -1.1.1
        

- 漏洞信息

4876
MIT Kerberos 5 krshd Overflow
Local Access Required, Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Local or remote users can obtain root access on the system running krshd from the MIT port of Kerberos 5. The vulnerability is a buffer overrun in the krb_rd_req() function which is used by essentially all Kerberos-authenticated services that use Kerberos 4 compatibility code for authentication within the MIT Kerberos 5 source distributions.

- 时间线

2000-05-28 2000-05-17
Unknow Unknow

- 解决方案

Upgrade to version krb5-1.2 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: Disable the krshd program completely until a patched version can be installed.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站