发布时间 :1999-07-28 00:00:00
修订时间 :2008-09-10 15:04:04

[原文]The Microsoft Jet database engine allows an attacker to modify text files via a database query, aka the "Text I-ISAM" vulnerability.

[CNNVD]Microsoft JET Text I-ISAM 漏洞(CNNVD-199907-031)

        Microsoft Jet数据库引擎存在漏洞。远程攻击者可以通过数据库请求修改文本文件,也称为"Text I-ISAM"漏洞。

- CVSS (基础分值)

CVSS分值: 7.6 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:microsoft:jet:3.51Microsoft Jet 3.51
cpe:/a:microsoft:jet:4.0Microsoft Jet 4.0
cpe:/a:microsoft:jet:3.5Microsoft Jet 3.5

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  19990728 Alert : MS Office 97 Vulnerability
(UNKNOWN)  MS  MS99-030

- 漏洞信息

Microsoft JET Text I-ISAM 漏洞
高危 设计错误
1999-07-28 00:00:00 2007-03-30 00:00:00
        Microsoft Jet数据库引擎存在漏洞。远程攻击者可以通过数据库请求修改文本文件,也称为"Text I-ISAM"漏洞。

- 公告与补丁

        Microsoft has released a patch for this issue. To quote Microsoft advisory MS99-030:
         - The above web site provides separate pages for Office97 and
         Office2000. This is done in order to provide specific information
         about the vulnerabilities affecting the products. The patch for
         Office97 and Office2000 (and indeed for all affected products) is
         exactly the same, and both pages link to exactly the same patch.
         The patch will determine what version(s) of Jet are present on
         the machine and apply all of the needed corrections.
         - The patch is suitable for use by all language packs.
         - The patch applies to Jet 3.5 and all subsequent versions. Older
         versions of Jet are no longer supported, and we recommend that
         affected customers upgrade to a supported version.
         - The patch is suitable for widespread deployment via Microsoft(r)
         Systems Management Server(r). Users who wish to manually apply
         patches for specific versions of Jet should consult the FAQ for
         information on how to do this.
        An additional patch made available by Microsoft, exists at the following location:

- 漏洞信息

Microsoft Jet Database Text I-ISAM Arbitrary File Modification
Input Manipulation
Loss of Integrity Patch / RCS
Vendor Verified

- 漏洞描述

- 时间线

1999-07-29 Unknow
Unknow Unknow

- 解决方案


Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete