CVE-2000-0189
CVSS5.0
发布时间 :2000-03-01 00:00:00
修订时间 :2008-09-10 15:03:16
NMCO    

[原文]ColdFusion Server 4.x allows remote attackers to determine the real pathname of the server via an HTTP request to the application.cfm or onrequestend.cfm files.


[CNNVD]Allaire ColdFusion远程服务器信息泄露漏洞(CNNVD-200003-003)

        
        Allaire ColdFusion是Macromedia 公司开发的一款Web应用服务器软件。
        Allaire ColdFusion application.cfm的脚本实现上存在漏洞,远程攻击者可能收集到主机相关的一些有用信息。
        正常的ColdFusion模板调用错误会被或者 / 捕获。但是当Web站点有一个application.cfm(或者onrequestend.cfm)时,如果用户试图从客户端直接调用它,ColdFusion将返回一个错误信息页面,其中会显示Web服务器的根路径。因为这两个模板是ColdFusion保留的用来进行应用层设置,不该直接从Web客户端调用。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:allaire:coldfusion_server:4.0
cpe:/a:allaire:coldfusion_server:4.5
cpe:/a:allaire:coldfusion_server:4.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0189
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0189
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200003-003
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1021
(UNKNOWN)  BID  1021

- 漏洞信息

Allaire ColdFusion远程服务器信息泄露漏洞
中危 其他
2000-03-01 00:00:00 2005-05-02 00:00:00
远程※本地  
        
        Allaire ColdFusion是Macromedia 公司开发的一款Web应用服务器软件。
        Allaire ColdFusion application.cfm的脚本实现上存在漏洞,远程攻击者可能收集到主机相关的一些有用信息。
        正常的ColdFusion模板调用错误会被或者 / 捕获。但是当Web站点有一个application.cfm(或者onrequestend.cfm)时,如果用户试图从客户端直接调用它,ColdFusion将返回一个错误信息页面,其中会显示Web服务器的根路径。因为这两个模板是ColdFusion保留的用来进行应用层设置,不该直接从Web客户端调用。
        

- 公告与补丁

        厂商补丁:
        Allaire
        -------
        这个问题已经在Allaire ColdFusion Server 4.5.1 中解决,请更新到4.5.1以上版本:
        
        http://download.macromedia.com/

- 漏洞信息

10494
ColdFusion onrequestend.cfm Path Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2000-03-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.5.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站