CVE-2000-0177
CVSS10.0
发布时间 :2000-03-02 00:00:00
修订时间 :2008-09-10 15:03:09
NMCOES    

[原文]DNSTools CGI applications allow remote attackers to execute arbitrary commands via shell metacharacters.


[CNNVD]DNSTools输入验证漏洞(CNNVD-200003-004)

        DNSTools CGI应用程序存在漏洞。远程攻击者借助shell元字符可以执行任意命令。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0177
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0177
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200003-004
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1028
(UNKNOWN)  BID  1028
http://archives.neohapsis.com/archives/bugtraq/2000-03/0000.html
(UNKNOWN)  BUGTRAQ  20000302 DNSTools v1.08 has no input validation

- 漏洞信息

DNSTools输入验证漏洞
危急 输入验证
2000-03-02 00:00:00 2005-10-20 00:00:00
远程  
        DNSTools CGI应用程序存在漏洞。远程攻击者借助shell元字符可以执行任意命令。

- 公告与补丁

        Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.
        The vendor has been contacted and have patched the 1.10 release of DNSTools. See message from Wolfgang Wiese in reference section.
        The best short term solution is to disable the DNSTools CGIs all together. If you feel confident, the code can be editted to prevent the vulnerabilities by dictating that only acceptable characters be allowed in post variables. This could be achieved as follows:
        if(!($domain_name =~ /^[a-zA-Z]*$/)) { print "Error"; exit -1;};
        Assuming only A-Z and a-z are allowable characters. Please note, this will not address all the problematic post variables, nor is it guaranteed to eliminate other problems.

- 漏洞信息 (19786)

DNSTools Software DNSTools 1.0.8/1.10 Input Validation Vulnerability (EDBID:19786)
cgi remote
2000-03-02 Verified
0 Jonathan Leto
N/A [点击下载]
source: http://www.securityfocus.com/bid/1028/info

A vulnerability exists in the 1.0.8 release of DNSTools (labeled on some areas of their site as 1.08), from DNSTools Software. By manipulating the contents of certain post variables, arbitrary code may be executed.

Note that version 1.10 is reportedly still vulnerable. See message from Wolfgang Wiese <wolfgang.wiese@rrze.uni-erlangen.de> in reference section.

The problem stems from the following code:

$host_name = $CGI->param("host_name"); 
$domain_name = $CGI->param("domain_name");

$error_description = ""; 
my $error_code = system("/usr/local/dnstools/delete_mx -d \"$domain_name\" -n \"$host_name\"");

No escaping or input validation is performed. This makes it easy for a would be attacker to execute arbitrary commands, as the user the webserver or cgi-bin is being run as.

The key to this exploit is causing the system() call to execute commands other than the intended one. The following would cause a directory listing: GET /~jed/cgi-bin/test.pl?domain_name=\"\;ls\" HTTP/1.0		

- 漏洞信息

13633
DNSTools Multiple CGI Application Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public Third-party Verified, Uncoordinated Disclosure

- 漏洞描述

- 时间线

2000-03-02 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

DNSTools Input Validation Vulnerability
Input Validation Error 1028
Yes No
2000-03-02 12:00:00 2009-07-11 01:56:00
This vulnerability was posted to the Bugtraq mailing list by Jonathan Leto <jonathan@leto.net> on March 2, 2000.

- 受影响的程序版本

DNSTools Software DNSTools 1.10
DNSTools Software DNSTools 1.0.8

- 漏洞讨论

A vulnerability exists in the 1.0.8 release of DNSTools (labeled on some areas of their site as 1.08), from DNSTools Software. By manipulating the contents of certain post variables, arbitrary code may be executed.

Note that version 1.10 is reportedly still vulnerable. See message from Wolfgang Wiese &lt;wolfgang.wiese@rrze.uni-erlangen.de&gt; in reference section.

The problem stems from the following code:

$host_name = $CGI-&gt;param("host_name");
$domain_name = $CGI-&gt;param("domain_name");

$error_description = "";
my $error_code = system("/usr/local/dnstools/delete_mx -d \"$domain_name\" -n \"$host_name\"");

No escaping or input validation is performed. This makes it easy for a would be attacker to execute arbitrary commands, as the user the webserver or cgi-bin is being run as.

- 漏洞利用

The key to this exploit is causing the system() call to execute commands other than the intended one. The following would cause a directory listing: GET /~jed/cgi-bin/test.pl?domain_name=\"\;ls\" HTTP/1.0

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

The vendor has been contacted and have patched the 1.10 release of DNSTools. See message from Wolfgang Wiese <wolfgang.wiese@rrze.uni-erlangen.de> in reference section.

The best short term solution is to disable the DNSTools CGIs all together. If you feel confident, the code can be editted to prevent the vulnerabilities by dictating that only acceptable characters be allowed in post variables. This could be achieved as follows:

if(!($domain_name =~ /^[a-zA-Z]*$/)) { print "Error"; exit -1;};

Assuming only A-Z and a-z are allowable characters. Please note, this will not address all the problematic post variables, nor is it guaranteed to eliminate other problems.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站