CVE-2000-0157
CVSS7.2
发布时间 :2000-02-01 00:00:00
修订时间 :2008-09-10 15:03:07
NMCO    

[原文]NetBSD ptrace call on VAX allows local users to gain privileges by modifying the PSL contents in the debugging process.


[CNNVD]NetBSD跟踪进程(2)漏洞 (CNNVD-200002-014)

        NetBSD VAX上的跟踪进程存在漏洞。本地用户可以通过修改调试进程中的PSL内容提升特权。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0157
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0157
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200002-014
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/992
(UNKNOWN)  BID  992
ftp://ftp.NetBSD.ORG/pub/NetBSD/misc/security/advisories/NetBSD-SA1999-012.txt.asc
(UNKNOWN)  NETBSD  1999-012

- 漏洞信息

NetBSD跟踪进程(2)漏洞
高危 其他
2000-02-01 00:00:00 2005-05-02 00:00:00
本地  
        NetBSD VAX上的跟踪进程存在漏洞。本地用户可以通过修改调试进程中的PSL内容提升特权。

- 公告与补丁

        Current versions of the NetBSD tree (-current) are not vulnerable. If you are running a kernel built from sources prior to 12/12/99, on VAX hardware, you should upgrade immediately.
        The following patch can be applied to 1.4.1 kernels:
        Index: machdep.c
        ===================================================================
        RCS file: /cvsroot/syssrc/sys/arch/vax/vax/machdep.c,v
        retrieving revision 1.76.2.1
        diff -c -r1.76.2.1 machdep.c
        *** machdep.c 1999/04/16 16:26:01 1.76.2.1
        - --- machdep.c 1999/12/12 11:08:46
        ***************
        *** 770,776 ****
         tf->fp = regs->fp;
         tf->sp = regs->sp;
         tf->pc = regs->pc;
        ! tf->psl = regs->psl;
         return 0;
         }
        - --- 770,777 ----
         tf->fp = regs->fp;
         tf->sp = regs->sp;
         tf->pc = regs->pc;
        ! tf->psl = (regs->psl|PSL_U|PSL_PREVU) &
        ! ~(PSL_MBZ|PSL_IS|PSL_IPL1F|PSL_CM); /* Allow compat mode? */
         return 0;
         }

- 漏洞信息

7573
NetBSD on VAX ptrace Call PSL Content Modification
Local Access Required Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

NetBSD on VAX contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when a malicious user constructs a wrapper program using the ptrace system call that can modify the hardware privileges of a process. This flaw may lead to a loss of integrity.

- 时间线

1999-12-12 Unknow
Unknow Unknow

- 解决方案

Upgrade to version NetBSD-current, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: apply machdep.c patch.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站