CVE-1999-1580
CVSS7.2
发布时间 :1995-08-23 00:00:00
修订时间 :2008-09-05 16:19:51
NMCO    

[原文]SunOS sendmail 5.59 through 5.65 uses popen to process a forwarding host argument, which allows local users to gain root privileges by modifying the IFS (Internal Field Separator) variable and passing crafted values to the -oR option.


[CNNVD]Sendmail V.5 -oR特权提升漏洞(CNNVD-199508-003)

        SunOS sendmail 5.59到5.65版本使用popen处理转发主机参数。本地用户通过修改IFS
        (内部字段分隔符
        )变量和传递畸形值给-oR选项提升根特权。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sun:sunos:4.1.3u1Sun SunOS 4.1.3u1
cpe:/o:sun:sunos:4.1.3cSun SunOS 4.1.3c
cpe:/o:sun:sunos:4.1.1Sun SunOS 4.1.1
cpe:/a:sendmail:sendmail:5.65
cpe:/o:sun:sunos:4.1.4Sun SunOS 4.1.4
cpe:/o:sun:sunos:4.1.3Sun SunOS 4.1.3
cpe:/o:sun:sunos:4.1.4jl
cpe:/o:sun:sunos:4.1.2Sun SunOS 4.1.2
cpe:/a:sendmail:sendmail:5.59
cpe:/a:sendmail:sendmail:5.61

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1580
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1580
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199508-003
(官方数据源) CNNVD

- 其它链接及资源

http://www.cert.org/advisories/CA-95.11.sun.sendmail-oR.vul
(VENDOR_ADVISORY)  CERT  CA-1995-11
http://www.kb.cert.org/vuls/id/3278
(VENDOR_ADVISORY)  CERT-VN  VU#3278
http://www.securityfocus.com/bid/7829
(UNKNOWN)  BID  7829
http://www.auscert.org.au/render.html?it=1853&cid=1978
(VENDOR_ADVISORY)  AUSCERT  AA-95.09
http://www.alw.nih.gov/Security/8lgm/8lgm-Advisory-21.html
(UNKNOWN)  MISC  http://www.alw.nih.gov/Security/8lgm/8lgm-Advisory-21.html

- 漏洞信息

Sendmail V.5 -oR特权提升漏洞
高危 输入验证
1995-08-23 00:00:00 2005-10-20 00:00:00
远程  
        SunOS sendmail 5.59到5.65版本使用popen处理转发主机参数。本地用户通过修改IFS
        (内部字段分隔符
        )变量和传递畸形值给-oR选项提升根特权。

- 公告与补丁

        This issue has been addressed in Sendmail versions 8.6.12 and later. Users should upgrade to recent versions of Sendmail to address this and other known vulnerabilities. Upgrades are especially advised if V.5 is still being used.
        The status of fixes for SunOS 4.1.x is currently not known. Those that are running affected versions of SunOS should contact the vendor to determine the availability of fixes.

- 漏洞信息

14880
SunOS Sendmail -oR Option IFS Variable Privilege Escalation

- 漏洞描述

Unknown or Incomplete

- 时间线

1995-09-10 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站