CVE-1999-1468
CVSS6.2
发布时间 :1991-10-22 00:00:00
修订时间 :2008-09-10 15:01:59
NMCO    

[原文]rdist in various UNIX systems uses popen to execute sendmail, which allows local users to gain root privileges by modifying the IFS (Internal Field Separator) variable.


[CNNVD]UNIX rdist IFS提升特权漏洞(CNNVD-199110-001)

        多种UNIX系统中的rdist使用popen执行邮件发送,本地用户可以通过修改IFS(内部字段分隔符)变量提升根特权。

- CVSS (基础分值)

CVSS分值: 6.2 [中等(MEDIUM)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sun:sunos:4.1.1Sun SunOS 4.1.1
cpe:/o:sgi:irix:3.3
cpe:/o:sgi:irix:3.3.2
cpe:/o:cray:unicos:6.0Cray UNICOS 6.0
cpe:/o:sun:sunos:4.1psr_aSun SunOS 4.1PSR_A
cpe:/o:sun:sunos:4.0.3cSun SunOS 4.0.3c
cpe:/a:next:next:2.1
cpe:/a:next:next:2.0
cpe:/o:cray:unicos:6.1Cray UNICOS 6.1
cpe:/o:sun:sunos:4.0.3Sun SunOS 4.0.3
cpe:/o:sun:sunos:4.1Sun SunOS 4.1
cpe:/o:sgi:irix:3.3.1
cpe:/o:cray:unicos:6.0eCray UNICOS 6.0E
cpe:/o:sgi:irix:4.0
cpe:/o:sgi:irix:3.3.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1468
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1468
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199110-001
(官方数据源) CNNVD

- 其它链接及资源

http://www.cert.org/advisories/CA-91.20.rdist.vulnerability
(VENDOR_ADVISORY)  CERT  CA-91.20
http://www.securityfocus.com/bid/31
(VENDOR_ADVISORY)  BID  31
http://www.alw.nih.gov/Security/8lgm/8lgm-Advisory-01.html
(UNKNOWN)  MISC  http://www.alw.nih.gov/Security/8lgm/8lgm-Advisory-01.html
http://www.osvdb.org/8106
(UNKNOWN)  OSVDB  8106
http://www.iss.net/security_center/static/7160.php
(UNKNOWN)  XF  rdist-popen-gain-privileges(7160)

- 漏洞信息

UNIX rdist IFS提升特权漏洞
中危 未知
1991-10-22 00:00:00 2005-05-02 00:00:00
本地  
        多种UNIX系统中的rdist使用popen执行邮件发送,本地用户可以通过修改IFS(内部字段分隔符)变量提升根特权。

- 公告与补丁

        

- 漏洞信息

8106
Multiple UNIX Vendor rdist popen IFS Variable Privilege Escalation
Local Access Required Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

rdist contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when the IFS variable is modified which may allow a user to set arbitrary local programs SUID. This flaw may lead to a loss of confidentiality and integrity.

- 时间线

1991-04-23 Unknow
1991-04-23 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However Sun (100383-06), Cray, SGI, and NeXTstep have released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站