CVE-1999-1456
CVSS5.0
发布时间 :1999-12-31 00:00:00
修订时间 :2008-09-05 16:19:34
NMCO    

[原文]thttpd HTTP server 2.03 and earlier allows remote attackers to read arbitrary files via a GET request with more than one leading / (slash) character in the filename.


[CNNVD]thttpd HTTP 文件任意读取漏洞(CNNVD-199912-143)

        thttpd HTTP 服务器 2.03及其之前的版本存在漏洞。远程攻击者通过在文件名中带有多个的行距/(斜线)字符的GET请求来读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1456
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1456
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199912-143
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/1809.php
(VENDOR_ADVISORY)  XF  thttpd-file-read(1809)
http://www.securityfocus.com/archive/1/10368
(VENDOR_ADVISORY)  BUGTRAQ  19980819 thttpd 2.04 released (fwd)
http://www.acme.com/software/thttpd/thttpd.html#releasenotes
(UNKNOWN)  CONFIRM  http://www.acme.com/software/thttpd/thttpd.html#releasenotes

- 漏洞信息

thttpd HTTP 文件任意读取漏洞
中危 未知
1999-12-31 00:00:00 2006-08-31 00:00:00
远程  
        thttpd HTTP 服务器 2.03及其之前的版本存在漏洞。远程攻击者通过在文件名中带有多个的行距/(斜线)字符的GET请求来读取任意文件。

- 公告与补丁

        

- 漏洞信息

7361
thttpd libhttpd.c Double Slash Asbolute Path Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality Upgrade
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

1998-08-10 Unknow
1998-08-10 1998-08-10

- 解决方案

Upgrade to version 2.04 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站