CVE-1999-1402
CVSS2.1
发布时间 :1997-05-17 00:00:00
修订时间 :2016-10-17 22:04:05
NMCOE    

[原文]The access permissions for a UNIX domain socket are ignored in Solaris 2.x and SunOS 4.x, and other BSD-based operating systems before 4.4, which could allow local users to connect to the socket and possibly disrupt or control the operations of the program using that socket.


[CNNVD]Solaris UNIX域套接字权限许可和访问控制漏洞(CNNVD-199705-017)

        Solaris 2.x版本、SunOS 4.x版本及其它基于BSD4.4版本以前操作系统的UNIX域套接字访问许可存在漏洞。本地用户可以利用该漏洞连接套接字并可能利用套接字干扰或控制程序的操作。
        

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sun:solaris:2.5.1
cpe:/o:sun:solaris:2.6::x86
cpe:/o:sun:solaris:2.5::x86
cpe:/o:freebsd:freebsd:2.2.3FreeBSD 2.2.3
cpe:/o:freebsd:freebsd:2.2.2FreeBSD 2.2.2
cpe:/o:sun:solaris:2.5.1::ppc
cpe:/o:freebsd:freebsd:2.2.5FreeBSD 2.2.5
cpe:/o:freebsd:freebsd:3.1FreeBSD 3.1
cpe:/o:sun:solaris:2.5
cpe:/o:freebsd:freebsd:2.2.4FreeBSD 2.2.4
cpe:/o:freebsd:freebsd:2.2.6FreeBSD 2.2.6
cpe:/o:freebsd:freebsd:3.0FreeBSD 3.0
cpe:/o:sun:solaris:2.6
cpe:/o:sun:solaris:2.5.1::x86
cpe:/o:sun:solaris:2.0
cpe:/o:sun:sunos:4.0Sun SunOS 4.0
cpe:/o:freebsd:freebsd:2.2.8FreeBSD 2.2.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1402
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1402
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199705-017
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=87602167418317&w=2
(UNKNOWN)  BUGTRAQ  19970517 UNIX domain socket (Solarisx86 2.5)
http://marc.info/?l=bugtraq&m=87602248718482&w=2
(UNKNOWN)  BUGTRAQ  19971003 Solaris 2.6 and sockets
http://www.iss.net/security_center/static/7172.php
(UNKNOWN)  XF  sun-domain-socket-permissions(7172)
http://www.securityfocus.com/bid/456
(VENDOR_ADVISORY)  BID  456

- 漏洞信息

Solaris UNIX域套接字权限许可和访问控制漏洞
低危 未知
1997-05-17 00:00:00 2005-05-02 00:00:00
本地  
        Solaris 2.x版本、SunOS 4.x版本及其它基于BSD4.4版本以前操作系统的UNIX域套接字访问许可存在漏洞。本地用户可以利用该漏洞连接套接字并可能利用套接字干扰或控制程序的操作。
        

- 公告与补丁

        

- 漏洞信息 (19346)

FreeBSD <= 3.1,Solaris <= 2.6 Domain Socket Vulnerability (EDBID:19346)
freebsd local
1997-06-19 Verified
0 Thamer Al-Herbish
N/A [点击下载]
source: http://www.securityfocus.com/bid/456/info


Solaris 2.6 and many other unices/clones have a serious problem with their unix domain socket implementation that has it's origins in old BSD code. Any unix socket created by any application is set mode 4777. In Solaris versions 2.5 and earlier, the permissions were ignored completely. The applications are vulnerable to being connected to and written to by anyone. This could lead to a whole number of application-specific security compromises. 

Here is some sample code (by Nirva):

#include <stdio.h>
#include <stdlib.h>
#include <sys/un.h>
#include <sys/socket.h>

main(int argc, char *argv[])
{
struct sockaddr_un addr;
int s;

s = socket(AF_UNIX, SOCK_STREAM, 0);

bzero(&addr, sizeof(addr));
addr.sun_family = AF_UNIX;
strcpy(addr.sun_path, "/tmp/yoursocket");
if (bind(s, (struct sockaddr *)&addr, sizeof(addr)) < 0) {
perror("bind");
exit(1);
}
sleep(100);

exit(0);
} 		

- 漏洞信息

1006
Multiple Vendor Unix Domain Socket

- 漏洞描述

Unknown or Incomplete

- 时间线

1997-05-17 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站