CVE-1999-1401
CVSS4.6
发布时间 :1996-12-05 00:00:00
修订时间 :2008-09-05 16:19:26
NMCOS    

[原文]Vulnerability in Desktop searchbook program in IRIX 5.0.x through 6.2 sets insecure permissions for certain user files (iconbook and searchbook).


[CNNVD]IRIX searchbook漏洞(CNNVD-199612-005)

        IRIX 5.0.x至6.2版本的Desktop searchbook程序由于将某些用户文件(iconbook和searchbook)设置为不安全权限而引起漏洞。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sgi:irix:6.0.1SGI IRIX 6.0.1
cpe:/o:sgi:irix:6.2SGI IRIX 6.2
cpe:/o:sgi:irix:5.2SGI IRIX 5.2
cpe:/o:sgi:irix:6.0SGI IRIX 6.0
cpe:/o:sgi:irix:5.3SGI IRIX 5.3
cpe:/o:sgi:irix:5.1.1SGI IRIX 5.1.1
cpe:/o:sgi:irix:5.1SGI IRIX 5.1
cpe:/o:sgi:irix:5.0
cpe:/o:sgi:irix:6.0.1::xfsSGI IRIX 6.0.1 XFS
cpe:/o:sgi:irix:5.3::xfsSGI IRIX 5.3 XFS
cpe:/o:sgi:irix:6.1SGI IRIX 6.1
cpe:/o:sgi:irix:5.0.1SGI IRIX 5.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1401
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1401
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199612-005
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/463
(VENDOR_ADVISORY)  BID  463
ftp://patches.sgi.com/support/free/security/advisories/19961201-01-PX
(VENDOR_ADVISORY)  SGI  19961201-01-PX
http://www.iss.net/security_center/static/7575.php
(UNKNOWN)  XF  irix-searchbook-permissions(7575)
http://www.osvdb.org/8563
(UNKNOWN)  OSVDB  8563

- 漏洞信息

IRIX searchbook漏洞
中危 其他
1996-12-05 00:00:00 2005-10-20 00:00:00
本地  
        IRIX 5.0.x至6.2版本的Desktop searchbook程序由于将某些用户文件(iconbook和searchbook)设置为不安全权限而引起漏洞。

- 公告与补丁

        Patches are available for this vulnerability at http//support.sgi.com. The following are the relevant patch numbers:
        IRIX 5.2: 1595
        IRIX 5.3: 1596
        IRIX 6.0.x: None. Users of 6.0.x should upgrade to at least 6.1
        IRIX 6.1: 1597
        IRIX 6.2: 1598

- 漏洞信息

8563
IRIX Desktop searchbook Insecure Permission Privilege Escalation
Local Access Required Race Condition
Loss of Integrity
Exploit Public

- 漏洞描述

IRIX contains a flaw that may allow a malicious local user to overwrite arbitrary files on the system. The issue is due to the searchbook program creating the iconbook and searchbook desktop files insecurely. It is possible for a user to use a symlink style attack to manipulate arbitrary files, resulting in a loss of integrity.

- 时间线

1996-12-06 Unknow
1996-12-06 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, IRIX has released patches to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

IRIX searchbook Vulnerability
Access Validation Error 463
No Yes
1996-12-05 12:00:00 2009-07-11 12:56:00
This vulnerability was first reported on December 5, 1996 in a Silicon Graphics security advisory.

- 受影响的程序版本

SGI IRIX 6.2
SGI IRIX 6.1
SGI IRIX 6.0.1 XFS
SGI IRIX 6.0.1
SGI IRIX 6.0
SGI IRIX 5.3 XFS
SGI IRIX 5.3
SGI IRIX 5.2
SGI IRIX 5.1.1
SGI IRIX 5.1
SGI IRIX 5.0.1
SGI IRIX 5.0
SGI IRIX 6.5.4
SGI IRIX 6.5.3 m
SGI IRIX 6.5.3 f
SGI IRIX 6.5.3
SGI IRIX 6.5.2 m
SGI IRIX 6.5.1
SGI IRIX 6.5
SGI IRIX 6.4
SGI IRIX 6.3

- 不受影响的程序版本

SGI IRIX 6.5.4
SGI IRIX 6.5.3 m
SGI IRIX 6.5.3 f
SGI IRIX 6.5.3
SGI IRIX 6.5.2 m
SGI IRIX 6.5.1
SGI IRIX 6.5
SGI IRIX 6.4
SGI IRIX 6.3

- 漏洞讨论

A vulnerability has been discovered in the searchbook application. This application is included with Silicon Graphic's Irix operating system, versions 5.x and 6.x. The searchbook application is used to find local and remote desktop icons. However, it creates files with incorrect permissions that can result in a major security problem.
<home dir>/.desktop-<hostname>/iconbook and
<home dir>/.desktop-<hostname>/searchbook
are created with mode 666. Presumably, searchbook will follow symbolic links, and can be used to create things such as .rhosts files.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Patches are available for this vulnerability at http//support.sgi.com. The following are the relevant patch numbers:
IRIX 5.2: 1595
IRIX 5.3: 1596
IRIX 6.0.x: None. Users of 6.0.x should upgrade to at least 6.1
IRIX 6.1: 1597
IRIX 6.2: 1598

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站