CVE-1999-1392
CVSS7.2
发布时间 :1990-10-03 00:00:00
修订时间 :2008-09-05 16:19:24
NMCOS    

[原文]Vulnerability in restore0.9 installation script in NeXT 1.0a and 1.0 allows local users to gain root privileges.


[CNNVD]NeXTstep /usr/etc/restore0.9 suid shell脚本漏洞(CNNVD-199010-003)

        NeXT 1.0a和1.0版本中的restore0.9安装脚本存在漏洞。本地用户可以提升根特权。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:next:next:1.0
cpe:/a:next:nex:1.0a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1392
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1392
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199010-003
(官方数据源) CNNVD

- 其它链接及资源

http://www.cert.org/advisories/CA-1990-06.html
(VENDOR_ADVISORY)  CERT  CA-1990-06
http://www.securityfocus.com/bid/9
(VENDOR_ADVISORY)  BID  9
http://ciac.llnl.gov/ciac/bulletins/b-01.shtml
(VENDOR_ADVISORY)  CIAC  B-01
http://www.iss.net/security_center/static/7144.php
(UNKNOWN)  XF  nextstep-restore09-root-access(7144)

- 漏洞信息

NeXTstep /usr/etc/restore0.9 suid shell脚本漏洞
高危 未知
1990-10-03 00:00:00 2005-10-20 00:00:00
本地  
        NeXT 1.0a和1.0版本中的restore0.9安装脚本存在漏洞。本地用户可以提升根特权。

- 公告与补丁

        NeXT owners running Release 1.0 or 1.0a should remove
        /usr/etc/restore0.9 from all disks. This file is installed by the
        "BuildDisk" application, so it should be removed from all
        systems built with the standard release disk, as well as from
        the standard release disk itself (which will prevent the file
        from being installed on system built with the standard
        release disk in the future). You must be root to remove this
        script, and the command that will remove the script is the
        following:
        # /bin/rm /usr/etc/restore0.9

- 漏洞信息

8769
NeXTstep restore0.9 Script Local Privilege Escalation
Local Access Required
Loss of Integrity Workaround

- 漏洞描述

- 时间线

1990-10-03 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this vulnerability. It is possible to temporarily work around the flaw by implementing the following workaround: Remove the '/usr/etc/restore0.9' script from your system by issuing the following command: # /bin/rm /usr/etc/restore0.9

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

NeXTstep /usr/etc/restore0.9 suid shell script Vulnerability
Unknown 9
No Yes
1990-10-02 12:00:00 2009-07-11 12:16:00

- 受影响的程序版本

NeXT NeXTstep 1.0 a
NeXT NeXTstep 1.0
NeXT NeXTstep 2.0

- 不受影响的程序版本

NeXT NeXTstep 2.0

- 漏洞讨论

A script exists as /usr/etc/restore0.9 that is a setuid shell
script. The existence of this script is a potential security
problem.

The script is only needed during the installation process and
isn't needed for normal usage. It is possible for any logged
in user to gain root access.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

NeXT owners running Release 1.0 or 1.0a should remove
/usr/etc/restore0.9 from all disks. This file is installed by the
"BuildDisk" application, so it should be removed from all
systems built with the standard release disk, as well as from
the standard release disk itself (which will prevent the file
from being installed on system built with the standard
release disk in the future). You must be root to remove this
script, and the command that will remove the script is the
following:

# /bin/rm /usr/etc/restore0.9

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站