CVE-1999-1390
CVSS7.2
发布时间 :1998-04-28 00:00:00
修订时间 :2008-09-05 16:19:24
NMCOES    

[原文]suidexec in suidmanager 0.18 on Debian 2.0 allows local users to gain root privileges by specifying a malicious program on the command line.


[CNNVD]Debian /usr/bin/suidexec漏洞(CNNVD-199804-024)

        Debian 2.0版本上suidmanager的suidexec存在漏洞。本地用户可以制定命令行中的恶意程序获得根权限。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1390
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1390
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199804-024
(官方数据源) CNNVD

- 其它链接及资源

http://darwin.bio.uci.edu/~mcoogan/bugtraq/msg00890.html
(VENDOR_ADVISORY)  BUGTRAQ  19980428 [Debian 2.0] /usr/bin/suidexec gives root access
http://www.securityfocus.com/bid/94
(UNKNOWN)  BID  94

- 漏洞信息

Debian /usr/bin/suidexec漏洞
高危 未知
1998-04-28 00:00:00 2005-10-20 00:00:00
本地  
        Debian 2.0版本上suidmanager的suidexec存在漏洞。本地用户可以制定命令行中的恶意程序获得根权限。

- 公告与补丁

        Upgrade to suidmanager 0.19 from
        ftp://ftp1.us.debian.org/debian/Incoming/suidmanager_0.19_all.deb.
        This removes the suidexec program entirely.

- 漏洞信息 (19080)

Debian suidmanager 0.18 Vulnerability (EDBID:19080)
linux dos
1998-04-28 Verified
0 Thomas Roessler
N/A [点击下载]
source: http://www.securityfocus.com/bid/94/info

/usr/bin/suidexec will execute arbitrary commands as root,
as soon as just _one_ suid root shell script can be found
on the system: Just invoke

/usr/bin/suidexec <your program> /path/to/script

- it will happily execute your program with euid = 0. This
is completely sufficient for doing arbitrary damage on the
system.

		

- 漏洞信息

6332
suidmanager suidexec Command Line Privilege Escalation

- 漏洞描述

Unknown or Incomplete

- 时间线

1998-04-28 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Debian /usr/bin/suidexec Vulnerability
Unknown 94
No No
1998-04-28 12:00:00 2009-07-11 12:16:00
This vulnerability was published on the BugTraq mailing list by Thomas Roessler <roessler@guug.de> on Tue, 28 Apr 1998.

- 受影响的程序版本

Debian suidmanager 0.18
+ Debian Linux 2.0
Debian suidmanager 0.19

- 不受影响的程序版本

Debian suidmanager 0.19

- 漏洞讨论

/usr/bin/suidexec will execute arbitrary commands as root,
as soon as just _one_ suid root shell script can be found
on the system: Just invoke

/usr/bin/suidexec &lt;your program&gt; /path/to/script

- it will happily execute your program with euid = 0. This
is completely sufficient for doing arbitrary damage on the
system.

- 漏洞利用

/usr/bin/suidexec &lt;your program&gt; /path/to/suid/script

- 解决方案

Upgrade to suidmanager 0.19 from
ftp://ftp1.us.debian.org/debian/Incoming/suidmanager_0.19_all.deb.
This removes the suidexec program entirely.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站