CVE-1999-1296
CVSS7.2
发布时间 :1997-04-29 00:00:00
修订时间 :2016-10-17 22:02:49
NMCO    

[原文]Buffer overflow in Kerberos IV compatibility libraries as used in Kerberos V allows local users to gain root privileges via a long line in a kerberos configuration file, which can be specified via the KRB_CONF environmental variable.


[CNNVD]Kerberos V Kerberos IV compatibility缓冲区溢出漏洞(CNNVD-199704-010)

        用于Kerberos V的Kerberos IV compatibility存在缓冲区溢出漏洞。本地用户可以通过kerberos配置文件中的超长行获得根权限,该文件可以通过KRB_CONF环境变量指定。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1296
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1296
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199704-010
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=87602167420878&w=2
(UNKNOWN)  BUGTRAQ  19970429 vulnerabilities in kerberos

- 漏洞信息

Kerberos V Kerberos IV compatibility缓冲区溢出漏洞
高危 缓冲区溢出
1997-04-29 00:00:00 2005-10-20 00:00:00
本地  
        用于Kerberos V的Kerberos IV compatibility存在缓冲区溢出漏洞。本地用户可以通过kerberos配置文件中的超长行获得根权限,该文件可以通过KRB_CONF环境变量指定。

- 公告与补丁

        

- 漏洞信息

4894
MIT Kerberos 5 KRB_CONF Elevated Privilege
Local Access Required Other
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

A local overflow exists in MIT Kerberos 5 when utilizing the Kerberos 4 compatibility libraries. Several Kerberos related programs fail to perform proper boundry checking on the KRB_CONF environment variable. With a specially crafted request, an attacker can gain unauthorized root access to vulnerable systems. This compromise would result in a loss of confidentiality, integrity, and/or availability.

- 时间线

1997-04-27 Unknow
1997-04-27 Unknow

- 解决方案

Upgrade to version 1.0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站