CVE-1999-1064
CVSS10.0
发布时间 :1999-08-22 00:00:00
修订时间 :2016-10-17 22:00:50
NMCOS    

[原文]Multiple buffer overflows in WindowMaker 0.52 through 0.60.0 allow attackers to cause a denial of service and possibly execute arbitrary commands by executing WindowMaker with a long program name (argv[0]).


[CNNVD]WindowMaker缓冲区溢出漏洞(CNNVD-199908-045)

        WindowMaker 0.52至0.60.0存在众多缓冲区溢出漏洞。远程攻击者可以执行WindowMaker的长程序名(argv[0])引起服务拒绝并可能执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-1064
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-1064
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199908-045
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=93555317429630&w=2
(UNKNOWN)  BUGTRAQ  19990822
http://marc.info/?l=bugtraq&m=93582070508957&w=2
(UNKNOWN)  BUGTRAQ  19990824 Re: WindowMaker bugs (was sub:none )
http://www.securityfocus.com/bid/596
(UNKNOWN)  BID  596

- 漏洞信息

WindowMaker缓冲区溢出漏洞
危急 缓冲区溢出
1999-08-22 00:00:00 2005-10-20 00:00:00
远程※本地  
        WindowMaker 0.52至0.60.0存在众多缓冲区溢出漏洞。远程攻击者可以执行WindowMaker的长程序名(argv[0])引起服务拒绝并可能执行任意代码。

- 公告与补丁

        Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 漏洞信息

9832
WindowMaker Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

1999-08-22 Unknow
1999-08-22 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

- 漏洞信息

WindowMaker Buffer Overflow Vulnerabilities
Boundary Condition Error 596
Yes Yes
1999-08-23 12:00:00 2009-07-11 12:56:00
First posted to the RedHat Linux Security mailing list by Stan Bubrouski <security@MailAndNews.com> on August 23, 1999.

- 受影响的程序版本

Windowmaker Windowmaker 0.53
+ FreeBSD FreeBSD 3.2
Windowmaker Windowmaker 0.52 -2
+ RedHat Linux 6.0
Windowmaker Windowmaker 0.20.1 -3
+ RedHat Linux 5.2 i386

- 漏洞讨论

There are a number of buffer overflow vulnerabilities known to exist in WindowMaker versions 0.52 and 0.60. These buffer overflows are due to several instances of strcpy() calls without bounds checking. The following section of code (along with other overflowable calls) appears multiple times in the WindowMaker source code:

char buffer[256];
...
...
if (class &amp;&amp; instance)
key1 = PLMakeString(strcat(strcat(strcpy(buffer,instance),"."),class));
else

In this example, the buffer 'buffer' can be overflown allowing arbitrary code to be executed.

It may be possible to overflow windowmaker remotely if the X server is configured insecurely.

wmaker is not setuid root by default.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站