CVE-1999-0996
CVSS7.5
发布时间 :1999-12-15 00:00:00
修订时间 :2008-09-09 08:36:36
NMCOE    

[原文]Buffer overflow in Infoseek Ultraseek search engine allows remote attackers to execute commands via a long GET request.


[CNNVD]Infoseek Ultraseek搜索引擎缓冲区溢出漏洞(CNNVD-199912-051)

        Infoseek Ultraseek搜索引擎存在缓冲区溢出漏洞。远程攻击者可以借助一个长GET请求执行命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0996
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0996
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199912-051
(官方数据源) CNNVD

- 其它链接及资源

http://www.osvdb.org/6490
(UNKNOWN)  OSVDB  6490
http://www.eeye.com/html/Research/Advisories/AD19991215.html
(UNKNOWN)  EEYE  AD19991215

- 漏洞信息

Infoseek Ultraseek搜索引擎缓冲区溢出漏洞
高危 缓冲区溢出
1999-12-15 00:00:00 2005-05-02 00:00:00
远程  
        Infoseek Ultraseek搜索引擎存在缓冲区溢出漏洞。远程攻击者可以借助一个长GET请求执行命令。

- 公告与补丁

        

- 漏洞信息 (19679)

Infoseek Ultraseek 2.1/3.1 for NT GET Buffer Overflow Vulnerability (EDBID:19679)
windows remote
1999-12-15 Verified
0 Ussr Labs
N/A [点击下载]
source: http://www.securityfocus.com/bid/874/info

Infoseek's Ultraseek enterprise search server listens on port 8765 by default for HTTP commands. The code that handles GET commands has an unchecked buffer that will allow arbitrary code to be executed if it is overflowed.

http://www.exploit-db.com/sploits/19679-1.zip

http://www.exploit-db.com/sploits/19679-2.zip		

- 漏洞信息

6490
Infoseek Ultraseek GET Request Overflow
Remote / Network Access Input Manipulation, Race Condition
Loss of Integrity
Exploit Public

- 漏洞描述

A remote overflow exists in Infoseek Ultraseek. Infoseek Ultraseek fails to check the buffer boundary in GET command. By sending a specially crafted GET request via port 8765, a remote attacker can cause cause a buffer overflow and execute arbitrary code, resulting in a loss of integrity.

- 时间线

1999-12-05 Unknow
1999-12-05 Unknow

- 解决方案

Upgrade to version 3.1.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站