CVE-1999-0947
CVSS7.5
发布时间 :1999-11-02 00:00:00
修订时间 :2016-10-17 21:59:58
NMCOE    

[原文]AN-HTTPd provides example CGI scripts test.bat, input.bat, input2.bat, and envout.bat, which allow remote attackers to execute commands via shell metacharacters.


[CNNVD]AN-HTTPd CGI漏洞(CNNVD-199911-010)

        AN-HTTPd提供的实例CGI脚本test.bat、input.bat、input2.bat以及envout.bat存在漏洞。远程攻击者可以通过shell元字符执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0947
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0947
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199911-010
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=94157187815629&w=2
(UNKNOWN)  BUGTRAQ  19991102 Some holes for Win/UNIX softwares
http://www.securityfocus.com/bid/762
(UNKNOWN)  BID  762

- 漏洞信息

AN-HTTPd CGI漏洞
高危 未知
1999-11-02 00:00:00 2005-05-02 00:00:00
远程※本地  
        AN-HTTPd提供的实例CGI脚本test.bat、input.bat、input2.bat以及envout.bat存在漏洞。远程攻击者可以通过shell元字符执行任意命令。

- 公告与补丁

        From the Bugtraq post:
        [1] remove the following test CGIs.
         cgi-bin/test.bat
         cgi-bin/input.bat
         cgi-bin/input2.bat
         ssi/envout.bat
        [2] Ver1.21 has been released at the official site.
        http://www.st.rim.or.jp/~nakata/

- 漏洞信息 (19587)

AN-HTTPd 1.2 b CGI Vulnerabilities (EDBID:19587)
windows remote
1999-11-02 Verified
0 UNYUN
N/A [点击下载]
source: http://www.securityfocus.com/bid/762/info

Certain versions of the AN-HTTPd server contain default CGI scripts that allow code to be executed remotely. This is due to poor sanity checking on user supplied data. 

http://www.xxx.yy/cgi-bin/input.bat?|dir..\..\windows 		

- 漏洞信息

11566
AN HTTPD Server input.bat Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

AN HTTP Server contains a flaw that may allow a remote attacker to execute arbitrary commands. The problem is that the 'input.bat' CGI script does not validate user-supplied input. It is possible that the flaw may allow arbitrary command execution resulting in a loss of integrity.

- 时间线

1999-11-02 Unknow
1999-11-02 Unknow

- 解决方案

Upgrade to version 1.21 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站