CVE-1999-0852
CVSS7.2
发布时间 :1999-12-02 00:00:00
修订时间 :2008-09-09 08:36:02
NMCOS    

[原文]IBM WebSphere sets permissions that allow a local user to modify a deinstallation script or its data files stored in /usr/bin.


[CNNVD]IBM Websphere配置权限漏洞(CNNVD-199912-020)

        IBM WebSphere的设置权限存在漏洞。本地用户可以卸载脚本或者修改存储于/usr/bin中的的数据文件。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0852
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0852
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199912-020
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/844
(UNKNOWN)  BID  844

- 漏洞信息

IBM Websphere配置权限漏洞
高危 配置错误
1999-12-02 00:00:00 2006-08-21 00:00:00
本地  
        IBM WebSphere的设置权限存在漏洞。本地用户可以卸载脚本或者修改存储于/usr/bin中的的数据文件。

- 公告与补丁

        A temporary solution is to change the permissions manually.
        Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 漏洞信息

9665
IBM WebSphere Script Permission Privilege Escalation

- 漏洞描述

Unknown or Incomplete

- 时间线

1999-12-02 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

IBM Websphere Installation Permissions Vulnerability
Configuration Error 844
No Yes
1999-12-02 12:00:00 2009-07-11 01:56:00
First posted to BugTraq by Martin Peter <srzpem@swissre.ch> on Demeber 2, 1999.

- 受影响的程序版本

IBM Websphere Application Server 3.0
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Novell Netware 5.0
- Sun Solaris 8_sparc

- 漏洞讨论

The IBM Websphere application server, when installed on Solaris (or possibly AIX), will create an deinstallation shellscript which is mode 777 in /usr/bin. The script is called by pkgmgr, which is run by root. This means that an attacker can modify the script and add malicious code to it, leading to a root compromise once it is run. IBM Websphere also installs many of its data files with mode 777 permissions.

- 漏洞利用

See discussion.

- 解决方案

A temporary solution is to change the permissions manually.

Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站