CVE-1999-0838
CVSS5.0
发布时间 :1999-12-01 00:00:00
修订时间 :2008-09-09 08:36:01
NMCOES    

[原文]Buffer overflow in Serv-U FTP 2.5 allows remote users to conduct a denial of service via the SITE command.


[CNNVD]Serv-U FTP服务 SITE PASS DoS 漏洞(CNNVD-199912-007)

        Serv-U FTP 2.5存在缓冲区溢出漏洞。远程用户可以通过SITE指令引起服务拒绝。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0838
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0838
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199912-007
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/859
(UNKNOWN)  BID  859

- 漏洞信息

Serv-U FTP服务 SITE PASS DoS 漏洞
中危 缓冲区溢出
1999-12-01 00:00:00 2005-05-02 00:00:00
远程  
        Serv-U FTP 2.5存在缓冲区溢出漏洞。远程用户可以通过SITE指令引起服务拒绝。

- 公告与补丁

        Version 2.5b has been released and is not susceptible to this attack. It is available from the Serv-U homepage:
        http://ftpserv-u.deerfield.com/download.cfm

- 漏洞信息 (19664)

Cat Soft Serv-U 2.5 a Server SITE PASS DoS Vulnerability (EDBID:19664)
windows remote
1999-12-02 Verified
0 Ussr Labs
N/A [点击下载]
source: http://www.securityfocus.com/bid/859/info

If the Serv-U FTP server receives an overly long argument to the SITE PASS command, it will crash. To issue this command, an attacker must be already logged in as an authenticated user, including an 'anonymous' user.

http://www.exploit-db.com/sploits/19664.zip		

- 漏洞信息

11278
Serv-U FTP Server SITE Command Overflow
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

Serv-U FTP Server contains a flaw that may allow a remote denial of service. The issue is triggered when issuing a malformed SITE command, which causes the server to crash, and will result in loss of availability for the server.

- 时间线

1999-12-02 Unknow
1999-12-02 Unknow

- 解决方案

Upgrade to version 5.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Serv-U FTP Server SITE PASS DoS Vulnerability
Boundary Condition Error 859
Yes No
1999-12-02 12:00:00 2006-04-20 07:46:00
Disovered by Dark Spyrit. Posted to Bugtraq on December 2, 1999 by USSR Labs.

- 受影响的程序版本

Cat Soft Serv-U 2.5 a
- Microsoft Windows 3.1
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
Cat Soft Serv-U 2.5 b
- Microsoft Windows 3.1
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0

- 不受影响的程序版本

Cat Soft Serv-U 2.5 b
- Microsoft Windows 3.1
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0

- 漏洞讨论

If the Serv-U FTP server receives an overly long argument to the SITE PASS command, it will crash. To issue this command, an attacker must be already logged in as an authenticated user, including an 'anonymous' user.

- 漏洞利用

Source code to USSR's exploit:

- 解决方案

Version 2.5b has been released and is not susceptible to this attack. It is available from the Serv-U homepage:

http://ftpserv-u.deerfield.com/download.cfm

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站