发布时间 :1999-11-09 00:00:00
修订时间 :2008-09-09 08:36:01

[原文]Buffer overflow in NFS server on Linux allows attackers to execute commands via a long pathname.

[CNNVD]Linux nfsd 远程缓冲区溢出漏洞(CNNVD-199911-035)


- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:debian:debian_linux:2.1Debian Debian Linux 2.1

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  19991109 undocumented bugs - nfsd
(UNKNOWN)  REDHAT  RHSA-1999:053-01
(UNKNOWN)  SUSE  19991110 Security hole in nfs-server < 2.2beta47 within nkita
(UNKNOWN)  DEBIAN  19991111 buffer overflow in nfs server

- 漏洞信息

Linux nfsd 远程缓冲区溢出漏洞
危急 缓冲区溢出
1999-11-09 00:00:00 2005-08-17 00:00:00

- 公告与补丁

        A temporary solution is to remove the setuid bit from nfsd and/or stop the nfsd service.
        A more long term solution is to upgrade to the newest version of nfsd for linux, since this has been fixed.
        Slackware 4.0:
        Slackware 7.0:
        Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 漏洞信息

Linux NFS Server Pathname Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

A remote overflow exists in NFS Server. The application fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request containing an overly long pathname on a read-write mounted NFS directory, a remote attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

1999-11-09 Unknow
Unknow Unknow

- 解决方案

Contact your vendor for an appropriate upgrade. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者