发布时间 :1999-08-17 00:00:00
修订时间 :2008-09-09 08:35:20

[原文]The w3-msql CGI script provided with Mini SQL allows remote attackers to view restricted directories.

[CNNVD]Mini SQL w3-msql漏洞。(CNNVD-199908-029)

        提供Mini SQL 的w3-msql CGI存在漏洞。远程攻击者可以借助此漏洞浏览限制目录。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

Mini SQL w3-msql漏洞。
高危 其他
1999-08-17 00:00:00 2005-05-02 00:00:00
        提供Mini SQL 的w3-msql CGI存在漏洞。远程攻击者可以借助此漏洞浏览限制目录。

- 公告与补丁

        Version 2.0.11 of the Mini SQL Server contains a fix for this problem. Please see the attached support page in the 'Credit' section for more details.

- 漏洞信息 (19466)

Hughes Technologies Mini SQL (mSQL) 2.0/2.0.10 Vulnerability (EDBID:19466)
multiple remote
1999-08-18 Verified
0 Gregory Duchemin
N/A [点击下载]

Under certain versions of Mini SQL, the w3-msql CGI script allows users to view directories which are set for private access via .htaccess files. W3-mSQL converts any form data passed to a script into global Lite variables and these variables can then be accessed by your script code.

When an HTML form is defined a field name is given to each element of the form. When the data is passed to W3-mSQL the field names are used as the variable names for the global variables. Once a set of variables has been created for each form element, the values being passed to the script are assigned to the variables. This is done automatically during start-up of the W3-mSQL program. 

First Approach:
This attack requires the attacker to know the location/directory structure of the site she is attacking.

Second Approach:
This approach will gain the intruder a DES encrypted password which they can then attempt to crack it via any number of popular cracking utilites. 		

- 漏洞信息

Mini SQL w3-msql Arbitrary Directory Access
Remote / Network Access Information Disclosure
Loss of Confidentiality Upgrade
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

1999-08-18 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.11 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete