发布时间 :1999-03-17 00:00:00
修订时间 :2008-09-09 08:34:36

[原文]suidperl in Linux Perl does not check the nosuid mount option on file systems, allowing local users to gain root access by placing a setuid script in a mountable file system, e.g. a CD-ROM or floppy disk.

[CNNVD]Linux Perl suidperl权限许可和访问控制漏洞(CNNVD-199903-038)

        Linux Perl上的suidperl不检查文件系统的nosuid安装选项。本地用户可以通过在挂载文件上放置设置用户名脚本访问根目录,如一个CD-ROM或floppy光盘。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

Linux Perl suidperl权限许可和访问控制漏洞
高危 其他
1999-03-17 00:00:00 2005-10-20 00:00:00
        Linux Perl上的suidperl不检查文件系统的nosuid安装选项。本地用户可以通过在挂载文件上放置设置用户名脚本访问根目录,如一个CD-ROM或floppy光盘。

- 公告与补丁


- 漏洞信息

Perl suidperl FileSystem Mount Arbitrary Code Execution
Local Access Required Misconfiguration, Race Condition
Loss of Confidentiality, Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

suidperl contains a flaw that may allow a local malicious user to gain access to unauthorized privileges. The issue is triggered when a user mounts media with files with a UID other than their own. The user can then run arbitrary scripts as that user (possibly root). Depending on the chosen script, this flaw may lead to a loss of confidentiality, integrity and/or availability.

- 时间线

1997-05-29 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 5.004_03 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround(s): Do not let untrusted users mount media. A Patch for the vulnerable versions (4.x and 5.x) was also released.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Perl suidmount Vulnerability
Environment Error 339
No Yes
1999-03-17 12:00:00 2009-07-11 12:16:00
First posted to BugTraq by Brian McCauley <B.A.McCauley@BHAM.AC.UK> on January 14, 1999.

- 受影响的程序版本

S.u.S.E. Linux 5.3
FreeBSD FreeBSD 2.2.8

- 不受影响的程序版本

FreeBSD FreeBSD 2.2.8

- 漏洞讨论

Perl 5.0004_4, included with S.u.S.E. Linux 5.3 and several other distributions, carries with it a vulnerability associated with suid script emulation. When suidperl obtains fstat information for the script it is running, it does not acknowledge whether the filesystem the script resides on is mounted nonsuid or not. Therefore, it is possible that suid perl scripts may be run from non-suid mounts with suid root priviliges -- allowing a root compromise.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 解决方案

- 相关参考