CVE-1999-0283
CVSS10.0
发布时间 :1999-01-01 00:00:00
修订时间 :2016-10-17 21:59:08
NMCOE    

[原文]The Java Web Server would allow remote users to obtain the source code for CGI programs.


[CNNVD]Java网络服务器获得CGI程序的源码漏洞(CNNVD-199901-015)

        Java网络服务器中存在漏洞。远程攻击者利用该漏洞获得CGI程序的源码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0283
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0283
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199901-015
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=88256790401004&w=2
(UNKNOWN)  BUGTRAQ  19970716 Viewable .jhtml source with JavaWebServer

- 漏洞信息

Java网络服务器获得CGI程序的源码漏洞
危急 未知
1999-01-01 00:00:00 2005-10-20 00:00:00
远程  
        Java网络服务器中存在漏洞。远程攻击者利用该漏洞获得CGI程序的源码。

- 公告与补丁

        

- 漏洞信息 (20375)

Sun Java Web Server 1.1 Beta Viewable .jhtml Source Vulnerability (EDBID:20375)
windows remote
1997-07-16 Verified
0 Brian Krahmer
N/A [点击下载]
source: http://www.securityfocus.com/bid/1891/info

A vulnerability exists in Sun Microsystems' JavaWebServer for Win32, version 1.1Beta. JavaWebServer is a Java-oriented web application development platform.

If a URL is submitted requesting a .jhtml file (an HTML document with embedded Java source) and a '.' or '/' character is appended to the filename, the source for that .jhtml file will be returned to the client, rather than being compiled on the server. As a result, system information which is not intended for disclosure to the client, such as database usernames and passwords, resource locations, website and network structure and business models, may be obtained by the attacker. As well as its inherent sensitivity, this type of information could potentially be used to implement other attacks on the host.

http://localhost/xyz.jhtml. 

or 

http://localhost/xyz.jhtml\		

- 漏洞信息

5862
Java Web Server Crafted Request CGI Source Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality Upgrade
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

1997-07-26 Unknow
1997-07-26 Unknow

- 解决方案

Upgrade to version 1.1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站