CVE-1999-0238
CVSS10.0
发布时间 :1997-08-01 00:00:00
修订时间 :2008-09-09 08:34:03
NMCOES    

[原文]php.cgi allows attackers to read any file on the system.


[CNNVD]php.cgi脚本可执行任意命令漏洞(CNNVD-199708-001)

        
        PHP/FI是现代PHP的前身,由Rasmus开发维护。是一个用来增强Web交互功能的软件包。
        早期版本的php.cgi程序有较多的漏洞,包括缓冲区溢出漏洞,还有导致任何系统文件可以被入侵者读取的漏洞。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php:php:1.0PHP PHP_FI 1.0
cpe:/a:php:php:2.0b10PHP PHP_FI 2.0b10
cpe:/a:php:php:2.0PHP PHP_FI 2.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0238
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0238
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199708-001
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

php.cgi脚本可执行任意命令漏洞
危急 其他
1997-08-01 00:00:00 2005-10-20 00:00:00
远程  
        
        PHP/FI是现代PHP的前身,由Rasmus开发维护。是一个用来增强Web交互功能的软件包。
        早期版本的php.cgi程序有较多的漏洞,包括缓冲区溢出漏洞,还有导致任何系统文件可以被入侵者读取的漏洞。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 停止此老程序的使用,换用功能更强大的PHP。
        厂商补丁:
        PHP
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.php.net

- 漏洞信息 (20567)

PHP PHP/FI 2.0 Directory Traversal Vulnerability (EDBID:20567)
cgi remote
1997-04-16 Verified
0 Shamanski
N/A [点击下载]
source: http://www.securityfocus.com/bid/2250/info

PHP/FI is an software suite designed to offer enhanced features to sites served via the World Wide Web. It is open source, freely available, and maintained by the PHP development team.

A problem with the software could allow remote users access to restricted resources. Due to a design problem in the software package, the PHP/FI software package allows a remote user to browse directories and view files stored on the local host. It is possible to view only those files which the UID of the local httpd process has access to read. A user with malicious intent could use this vulnerability to gather information on the local host, and possibly gain remote access to encrypted user passwords on a system not using the shadow password suite. 

http://www.someurl.com/php.cgi?/path/to/file 		

- 漏洞信息

137
PHP/FI php.cgi Absolute Path Request Arbitrary File Access
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality
Exploit Public

- 漏洞描述

- 时间线

1997-09-01 Unknow
1997-09-01 Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHP/FI Directory Traversal Vulnerability
Access Validation Error 2250
Yes No
1997-04-16 12:00:00 2009-07-11 04:46:00
This vulnerability was announced by Shamanski <jshaman@m-net.arbornet.org> on April 16, 1997 via Bugtraq.

- 受影响的程序版本

PHP PHP/FI 2.0

- 漏洞讨论

PHP/FI is an software suite designed to offer enhanced features to sites served via the World Wide Web. It is open source, freely available, and maintained by the PHP development team.

A problem with the software could allow remote users access to restricted resources. Due to a design problem in the software package, the PHP/FI software package allows a remote user to browse directories and view files stored on the local host. It is possible to view only those files which the UID of the local httpd process has access to read. A user with malicious intent could use this vulnerability to gather information on the local host, and possibly gain remote access to encrypted user passwords on a system not using the shadow password suite.

- 漏洞利用

http://www.someurl.com/php.cgi?/path/to/file

- 解决方案

Upgrades available:

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站