发布时间 :1997-10-19 00:00:00
修订时间 :2008-09-09 08:33:39

[原文]CGI PHP mylog script allows an attacker to read any file on the target server.

[CNNVD]PHP/FI 1.0/2.0示例脚本远程读取任意文件漏洞(CNNVD-199710-017)

        PHP/FI 是一种CGI语言,是PHP的前身。早期版本的PHP/FI中自带了一些例程文件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php:php:1.0PHP PHP_FI 1.0
cpe:/a:php:php:2.0b10PHP PHP_FI 2.0b10
cpe:/a:php:php:2.0PHP PHP_FI 2.0

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

PHP/FI 1.0/2.0示例脚本远程读取任意文件漏洞
高危 其他
1997-10-19 00:00:00 2005-05-02 00:00:00
        PHP/FI 是一种CGI语言,是PHP的前身。早期版本的PHP/FI中自带了一些例程文件。

- 公告与补丁

        * 删除mylog.phtml和mlog.phtml。

- 漏洞信息 (19553)

PHP/FI 1.0/FI 2.0/FI 2.0 b10 mylog/mlog Vulnerability (EDBID:19553)
php remote
1997-10-19 Verified
0 Bryan Berg
N/A [点击下载]

The PHP/FI package which was originally written by Rasmus Lerdorf is an is an HTML-embedded scripting language. Much of its syntax is borrowed from C, Java and Perl with a couple of unique PHP-specific features thrown in. The goal of the language is to allow web developers to write dynamically generated pages quickly.

Since its inception, PHP/FI has been turned over to another development team and is now known only as PHP. Certain versions of PHP/FI shipped with two flawed example script for logging examples. These scripts were mylog.html & mlog.html. in both mlog.html and mylog.html. The idea is to include a file for each type of logging stats, however, there is no escaping of slashes, so one can specify any file on the system.

The problem lies in the line:

<?include "$screen">

By exploiting this problem users can view any file on the system which the http daemon user id has access to.[fully
qualified path to any file on the system] 		

- 漏洞信息

PHP mylog.html screen Parameter Arbitrary File Access
Remote / Network Access Information Disclosure
Loss of Confidentiality Upgrade
Exploit Public Third-party Verified

- 漏洞描述

PHP/FI contains a flaw that allows a remote attacker to view arbitray files. The issue is due to the "mylog.html" sample script not sanitizing input passed to the "screen" variable. By supplying a fully qualified path and filename, the script will return the contents of the file.

- 时间线

1997-10-19 Unknow
1997-10-19 Unknow

- 解决方案

Upgrade to version 3.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete