CVE-1999-0066
CVSS7.5
发布时间 :1995-07-31 00:00:00
修订时间 :2008-09-09 08:33:39
NMCOE    

[原文]AnyForm CGI remote execution.


[CNNVD]AnyForm脚本远程可执行任意命令漏洞(CNNVD-199507-001)

        
        AnyForm是一个利用简单表单发送Email的CGI脚本,由John Roberts编写。
        AnyForm版本2(AnyForm2)实现上存在输入验证漏洞,远程攻击者可以利用此漏洞在主机上以Web进程的权限执行任意命令。
        AnyForm未经检查就把从表单得到的用户输入传递给SYSTEM系统调用,远程攻击者可能在输入中插入";"等转义字符而执行任意命令。
        <**>

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:john_s._roberts:anyform:2.0
cpe:/a:john_s._roberts:anyform:1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0066
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0066
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199507-001
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/719
(UNKNOWN)  BID  719

- 漏洞信息

AnyForm脚本远程可执行任意命令漏洞
高危 输入验证
1995-07-31 00:00:00 2006-11-16 00:00:00
远程  
        
        AnyForm是一个利用简单表单发送Email的CGI脚本,由John Roberts编写。
        AnyForm版本2(AnyForm2)实现上存在输入验证漏洞,远程攻击者可以利用此漏洞在主机上以Web进程的权限执行任意命令。
        AnyForm未经检查就把从表单得到的用户输入传递给SYSTEM系统调用,远程攻击者可能在输入中插入";"等转义字符而执行任意命令。
        <**>

- 公告与补丁

        厂商补丁:
        John Roberts
        ------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.uky.edu/AnyForm

- 漏洞信息 (19557)

John S.2 Roberts AnyForm 1.0/2.0 CGI Semicolon Vulnerability (EDBID:19557)
linux remote
1995-07-31 Verified
0 Paul Phillips
N/A [点击下载]
source: http://www.securityfocus.com/bid/719/info

AnyForm is a popular form CGI designed to support simple forms that deliver responses via email. Certain versions of AnyForm did not perform user supplied data sanity checking and could be exploited by remote intruders to execute arbitrary commands. These commands were issued as the UID which the web server runs as, typically 'nobody'. 

Exploit as taken from the original post on this issue:

To exploit, create a form with a hidden field something like this:

<input type="hidden" name="AnyFormTo" value="foo@bar.com;command-to-execute
with whatever arguments;/usr/lib/sendmail -t foo@bar.com ">

Then submit the form to the "AnyForm" CGI on the server to be attacked.
The value of this parameter is passed to this code:

SystemCommand="/usr/lib/sendmail -t " + AnyFormTo + " <" + CombinedFileName;
system(SystemCommand);

Since system invokes a shell, the semicolons are treated as command
delimeters and anything can be inserted		

- 漏洞信息

1116
AnyForm CGI AnyFormTo Parameter Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Third-party Verified

- 漏洞描述

- 时间线

1995-07-31 Unknow
1995-07-31 Unknow

- 解决方案

Upgrade to version 3.0 or 4.0 or higher, as they have been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站