CVE-1999-0058
CVSS7.5
发布时间 :1997-04-17 00:00:00
修订时间 :2008-09-09 08:33:39
NMCO    

[原文]Buffer overflow in PHP cgi program, php.cgi allows shell access.


[CNNVD]PHP/FI缓冲区溢出漏洞(CNNVD-199704-007)

        PHP cgi、php.cgi程序存在缓冲区溢出漏洞。可以利用该漏洞访问shell。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php:php:1.0PHP PHP_FI 1.0
cpe:/a:php:php:2.0b10PHP PHP_FI 2.0b10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-1999-0058
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-1999-0058
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-199704-007
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/712
(UNKNOWN)  BID  712

- 漏洞信息

PHP/FI缓冲区溢出漏洞
高危 缓冲区溢出
1997-04-17 00:00:00 2005-05-02 00:00:00
远程  
        PHP cgi、php.cgi程序存在缓冲区溢出漏洞。可以利用该漏洞访问shell。

- 公告与补丁

        This particular vulnerability was only present in beta versions of PHP/FI 2.0 and previous. If you are still running these versions (PHP/FI Version 2.0b10 and earlier) it is suggested that you upgrade to the newest version of PHP. The reference for the PHP development site is in the 'Credits' section of this vulnerability entry.

- 漏洞信息

1110
PHP/FI php.cgi FixFilename() Function Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

1997-04-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.0.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站